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Preface

This document supports the MPEG Audio Stream Analyzer application.

If you purchased an MTS 300 Series test system and are looking for information
about installation, first-time operation, or specifications, refer to the MTS 300
MPEG Test System Hardware and Software Installation Technical Reference,
Tektronix part number 071-0667-XX.

For the latest information about MTS 300 Series software features and bugs,
refer to the MPEG Test System Software Version 5.0 Read This First document,
Tektronix part number 071-0666-XX, that accompanied your test system,
software product, or upgrade.

Table i lists the MTS 300 Series MPEG Test System application version
supported by this manual. To verify an application version number, select Help
in the application menu bar; then select About from the Help menu.

Table i: MTS 300 Series MPEG Test System (V5.0) supported applications 

Application Supported version

MPEG-2 Audio Stream Analyzer V1.04 and above
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Contacting Tektronix

Product
Support

For questions about using Tektronix measurement products, call
toll free in North America:
1-800-833-9200
6:00 a.m. – 5:00 p.m. Pacific time

Or contact us by e-mail:
tm_app_supp@tek.com

For product support outside of North America, contact your
local Tektronix distributor or sales office.

Service
support

Tektronix offers a range of services, including Extended
Warranty Repair and Calibration services. Contact your local
Tektronix distributor or sales office for details.

For a listing of worldwide service centers, visit our web site.

Toll-free
Number

In North America:
1-800-833-9200
An operator can direct your call.

Postal 
Address

Tektronix, Inc.
Department or name (if known)
P.O. Box 500
Beaverton, OR 97077
USA

Web site www.tektronix.com
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Getting Started

Product Description
The MPEG Audio Stream Analyzer analyzes MPEG-1 and MPEG-2 audio layer
I and II specification binary streams. You can analyze an MPEG audio stream at
different levels for conformance of the bitstream to specifications using the
interpreted views and analysis functions enabled by the analyzer application.

The analyzer displays MPEG audio stream structures, items, and values in
graphical views, called interpreted views, as shown in Table 1–1. Page references
indicate where you can find more information about the specific view. See
Interpreted Views beginning on page 3–1 for general information on the types of
displays used for the interpreted views.

Table 1–1: MPEG Audio Stream Analyzer interpreted views  

MPEG-1 structures MPEG-2 structures

Audio Header (page 3–6) Multichannel Header (page 3–8)

Error Check (Cyclic Redundancy Check) 
(page 3–6)

Multichannel Error Check (Cyclic Redundancy
Check) (page 3–8)

Audio Allocation Table (page 3–5) Multichannel Composite Status Information
(page 3–7)

Scalefactor Selection Information (page 3–11) Low Frequency Enhancement Allocation 
(page 3–6)

Scalefactor Table (page 3–11) Multichannel Allocation Table (page 3–7)

Sample Table (page 3–11) Multichannel Scalefactor Selection Information
(page 3–9)

Ancillary Data (page 3–5) Delay Compensation (page 3–6)

Predictor Coefficient (page 3–10)

Low Frequency Scalefactor (page 3–7)

Multichannel Scalefactor Table (page 3–9)

Low Frequency Enhancement Sample Table
(page 3–7)

Multichannel Sample Table (page 3–9)

Multilingual Allocation Table (page 3–10)

Multilingual Scalefactor Selection Information
(page 3–10)

Multilingual Scalefactor Table (page 3–10)

Multilingual Sample Table (page 3–10)

Interpreted Views
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For each of the MPEG items listed in Table 1–1, one or more of the following
analyses may be available:

� Syntactic Analysis (conformance of the parameters to the MPEG standards)

� Semantic Analysis (conformance of the MPEG structure to the standards)

� CRC Analysis (adequate transmission performance)

The following list indicates the limitations of the analyzer:

� The analyzer cannot support a variable bitrate or a free bitrate.

� In an MPEG Layer III audio bitstream, the audio header is the only
processed syntax.

� The copyright_identification_bit and the copyright_identification_start fields
in the Multi-channel Header are not taken into account.

First Time Operation
The MPEG Audio Stream Analyzer is part of a suite of hardware and software
components used to create, generate, acquire, and analyze MPEG and DVB
transport and program streams. Before you can use the analyzer, ensure that you
have entered the correct password for your software configuration. To enable the
test system configuration you have purchased, use the procedure for entering the
general password described in the MPEG Test System Software Only Installation
Instructions, Tektronix part number 075-0630-XX.

Analyses

Limitations
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Operating Basics

This chapter is organized into the following sections:

NOTE. For basic Windows operating techniques such as minimizing windows or
using the scroll bars, refer to your Windows documentation.

� Starting the MPEG Audio Stream Analyzer describes how to start the
application.

� Functional Overview describes the application window types and the
application interface elements.

� MPEG Audio Stream Analyzer Views describes each of the views used in the
application and how to access them.

� Basic Operations describes common procedures used to display, analyze,
and decode audio streams.

� Menu Selections provides a table that summarizes the menu selections.

Starting the MPEG Audio Stream Analyzer

Double click the MPEG Audio Stream Analyzer icon in the MPEG Test
System program group window.
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Functional Overview
The MPEG Audio Stream Analyzer uses two window types to display audio
streams: an application window and secondary windows called view windows.

The basic application window looks similar to the following illustration.

TItle Bar
Menu Bar

Upper Toolbar

Status Bar
Edit Toolbar

The following sections describe the elements of the application window.

Title Bar. The title bar displays the application name and application icon. The
window control buttons are standard window controls and allow you to
minimize, maximize, and close the application window.

Application Window
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Menu Bar. The menu bar provides access to the commands you use to control the
display, analysis, and look of the MPEG Audio Stream Analyzer. A list of menu
selections is provided in Menu Selections beginning on page 2–21. Complete
descriptions of each menu selection are provided in the Menu Reference section
beginning on page 3–21.

Upper Toolbar. The Upper toolbar provides shortcut buttons to five commonly
used menu selections. These buttons, and the menu selection they represent, are
described in Table 2–1.

Table 2–1: Upper toolbar buttons 

Button Name Description

Open Displays the Open dialog box. Selecting this button is the
same as selecting Open from the File menu. See Opening
an Audio Stream File beginning on page 2–13.

Save as Displays the Save As dialog box. Selecting this button is the
same as selecting Save As from the File menu. See Saving
Audio Stream Files beginning on page 2–15.

First level view Displays the First Level view window for the active audio
stream. Selecting this button is the same as selecting First
level view from the Selection menu. See First Level View
beginning on page 2–8.

Add view Displays a submenu from which you specify a view to be
displayed. Selecting this button is the same as selecting
Add view from the Window menu. See Adding Views
beginning on page 2–12.

Main characteristics
view

Displays the Main Characteristics window for the active
audio stream. Selecting this button is the same as selecting
Main characteristics from the Selection Window. See Main
Characteristics View beginning on page 2–7.

Status Bar. The Status bar, located just above the Edit toolbar, provides you with
first level help on using the menus. As you highlight a menu item, the status bar
briefly describes the selection.
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Edit Toolbar. The Edit toolbar provides shortcut buttons to selections found in the
Edit menu. These buttons, described in Table 2–2, allow you to move through
the items of the displayed view and view the errors in the audio stream file.

Table 2–2: Edit toolbar buttons 

Button Name Description

First Displays the first item in the active view. Selecting this button is
the same as selecting First from the Edit menu.

Previous Displays the previous item in the active view. Selecting this
button is the same as selecting Previous from the Edit menu.

Go to Displays a dialog box that allows you to select the item number
of the active view you want displayed. Selecting this button is
the same as selecting Go to from the Edit menu.

Next Displays the next item in the active view. Selecting this button is
the same as selecting Next from the Edit menu.

Last Displays the last item in the active view. Selecting this button is
the same as selecting Last from the Edit menu.

Number of Items Counts the number of items in the element and displays the
number at the top of the Interpreted view. Selecting this button is
the same as selecting Number of Items from the Edit menu.

Next error Displays the next item that has an error in the audio stream file.
Selecting this button is the same as selecting Next error from
the Edit menu.
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View windows are used to display the structures of audio stream files at different
levels.

Application
window

View
window

Common View Window Elements. In addition to standard window controls, the
title bar of the view windows provides the following information:

� View type. The view type indicates the type of view displayed in the view
window.

NOTE. When the Channel view window is displayed, the view type indicated in
the title bar is First Level View. Also, the view type is not listed in the title bar if
the audio stream is opened using the Deferred-Time Analyzer.

View Windows
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� File name. The file name indicates the name of the audio stream file or the
transport stream from which the audio stream was extracted.

NOTE. If the view window is maximized, the view type and file name are
displayed in the title bar of the application window.

The top line of the First Level, Channel, and Interpreted view windows provide
the following information (refer to the illustration below):

� View type. The view type indicator will be the same as the view type
indicated in the title bar with the following exception: In the Channel view
the view type on the first line is Channel and the title bar reads
First Level View.

� Frame number. The frame number of the displayed element is relative to the
first synchronized frame. The number of the first synchronized frame is one.

� Position. The position of the displayed element is indicated in bytes (b) and
is relative to the first byte of the first synchronized frame. The position of the
first synchronized frame is zero.

� Time. The time stamp of the displayed element is indicated in seconds (s)
and is relative to the first byte of the first synchronized frame. The time of
the first synchronized frame is zero.

PositionView type TimeFrame number

The areas of the view windows below the top line are described briefly in the
next section, MPEG Audio Stream Analyzer Views, and more thoroughly in the
Reference section of this manual.
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MPEG Audio Stream Analyzer Views
You can use the MPEG Audio Stream Analyzer to view audio elementary
streams at different levels of detail. This section describes the views used by the
analyzer to display MPEG data and how to access them. See Interpreted Views
beginning on page 3–1, and see Additional Views beginning on page 3–12 for
more detailed information about the various view types used in the MPEG Audio
Stream Analyzer.

The Main Characteristics view window is displayed when you first open an
audio stream file.

This view provides quick access to the following information about the audio
stream:

� MPEG standard

� Layer

� Sampling frequency

� Mode

� Bitrate

� Center channel

� Surround channel

� Second stereo program

� Low frequency enhancement channel

� Multilingual channel

� Extension frame bitrate

Main Characteristics View
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You can access the Main Characteristics view from other views by selecting the
Main characteristics view button from the Upper toolbar, or by selecting Main
characteristics view from the Selection menu.

You cannot access the Main Characteristics view from the Binary, Hexadecimal,
or Wave Editor view windows.

When you open an audio stream file, the First Level view is displayed. The First
Level view provides you with a graphic representation of the elements associated
with the audio stream.

The lower portion of the window depicts the elements of the audio stream. Each
element is represented by an icon. Double-click an icon to access the interpreted
view of the audio stream element. If the audio data has been encoded using
MPEG-2 extensions, the icons for the extensions are shown on a separate line.

Add a new First Level view window to your display from a First Level or
Channel view window using one of the following techniques:

� Select Add View from the Window menu, and then select First Level from
the submenu.

� Select the Add View button from the Upper toolbar and select First Level
from the submenu.

Add a new First Level view to your display from an interpreted view by
selecting the First Level view icon from the Upper toolbar (see Table 2–1 on
page 2–3). If the active audio stream file uses MPEG-2 extensions, you will be
asked to select the associated extension file.

First Level View
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 Access interpreted views of MPEG elements by double-clicking the element
icons shown in Table 2–3. These icons are displayed in the First Level view
window. Page references indicate where you can find more information about the
interpreted view.

Table 2–3: Interpreted view icons 

MPEG-1
icon Interpreted view displayed

MPEG-2
icon Interpreted view displayed

Audio Header (page 3–6) Multichannel Audio Header
(page 3–8)

Error Check (Cyclic Redundancy
Check) (page 3–6)

Multichannel Error Check (Cyclic
Redundancy Check) (page 3–8)

Audio Allocation Table (page 3–5) Multichannel Composite Status
Information (page 3–7)

Scalefactor Selection Information
(page 3–11)

Low Frequency Enhancement
Allocation Table (page 3–6)

Scalefactor Table (page 3–11) Multichannel Allocation Table
(page 3–7)

Sample Table (page 3–11) Multichannel Scalefactor Selection
Information (page 3–9)

Ancillary Data (page 3–5) Delay Compensation (page 3–6)

Predictor Coefficient (page 3–10)

Low Frequency Scalefactor Table
(page 3–7)

Multichannel Scalefactor Table
(page 3–9)

Low Frequency Enhancement
Sample Table (page 3–7)

Multichannel Sample Table
(page 3–9)

Multilingual Allocation Table
(page 3–10)

Multilingual Scalefactor Selection
Information (page 3–10)

Multilingual Scalefactor Table
(page 3–10)

Multilingual Sample Table
(page 3–10)

Interpreted Views
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From the interpreted views, you can access two other views: Binary and
Hexadecimal.

The Binary and Hexadecimal views show the bit representation, in either binary
or hexadecimal format, of the interpreted view from which it was accessed.

You can display the Binary or Hexadecimal view windows using one of the
following techniques:

� Navigate to an interpreted view window for the syntax you want displayed,
and then select the Add view button on the Upper toolbar. When the
submenu is displayed, select Binary or Hexadecimal.

� Navigate to an interpreted view window for the syntax you want displayed,
and then select Add view from the Window menu. When the submenu is
displayed, select Binary or Hexadecimal.

The Channel view displays the number and type of channels used to encode the
audio information. The icons shown in Table 2–4 are used to depict the channel
types indicated.

Table 2–4: Channel view icons 
ÁÁÁÁ
ÁÁÁÁIcon

ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁType

ÁÁÁ
ÁÁÁIcon

ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁTypeÁÁÁÁÁÁÁÁÁÁ

ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ

Left, right, or dual channel
ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ

Single, center, or LFE channel

ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ

Left, right, or mono surround
channel

ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ
ÁÁÁÁÁÁÁÁÁÁ

Multilingual channel

Access the Channel view using the following procedure:

1. Navigate to the First Level view for the audio file.

2. Select Add View from the Window menu (or click the Add View icon from
the upper toolbar).

3. Select Channel View from the submenu and the Channel view window is
displayed.

You can decode an audio stream from this view by right-clicking the Left or
Right channel icons, which displays a submenu from which you select either
Decode (as a single channel), or Stereo. An overview of the decoding function is
described in Decoding Audio Stream Files on page 2–18.

Binary and Hexadecimal
Views

Channel View
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Immediately after you decode an audio stream file, the Wave Editor view
window is displayed. From this window you can view the decoded audio stream
waveform, play the decoded audio file, and save the audio file (or a portion of it)
as a .wav file. To listen to the decoded audio stream, you must have a sound card
installed on your computer.

To display the Wave Editor window, you must perform one of the decoding
procedures described in Decoding Audio Stream Files on page 2–18 or in
Decoding Audio Streams on page 3–13.

NOTE. The Wave Editor view window is displayed only after the analyzer has
finished decoding an audio stream file. The editing capabilities of the Wave
Editor are limited to selecting a portion of the decoded audio stream to save or
playback.

You can add another Wave Editor view window using the following procedure:

1. Ensure that the Wave Editor view window is the active view window.

2. Click the Add View command button from the Upper toolbar.

Alternatively, select Add view from the Window menu.

Wave Editor View



Operating Basics

2–12 MPEG Audio Stream Analyzer User Manual

You can add multiple view windows to the application window using one of the
following techniques:

� Select the Add View button from the Upper toolbar, and then select the type
of view window you want displayed from the submenu.

� Select Add View from the Window menu, and then select the type of view
window you want displayed from the submenu.

The views available from the submenus in both cases depend on the active view
window as described in Table 2–5.

Table 2–5: Add view options 

From this view window Select Add View to display

First Level view � An additional First Level view or
� A Channel view

Interpreted view � An additional interpreted view or
� A Binary or Hexadecimal view

Binary or Hexadecimal view � An interpreted view of the syntax or
� A Binary or Hexadecimal view

Channel view � A First Level view or
� An additional Channel view

Wave Editor � Another Wave Editor view window

Adding Views
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Basic Operations
This section describes how to open, save, print, analyze, and decode MPEG
audio stream files and how to exit the application.

The MPEG Audio Stream Analyzer can display audio elementary streams of the
following file formats:

� MPEG encoded audio stream files

� Audio elementary streams extracted from transport stream files, such as
those captured and saved with the Tektronix MPEG Test System Data Store
System

NOTE. The analyzer may take a few minutes to load extremely large audio
elementary stream files when the List file of type option is All files (automatic).

Opening an Audio Stream File. To open and analyze an audio stream file, use the
following procedure:

1. Select Open from the File menu. The Open dialog box is displayed.

2. From the List files of type drop down selection box, select one of the
following options:

� All files (automatic). If you select this option (the default option), the
analyzer automatically scans the entire file and then opens the audio
stream regardless of whether the file uses the multichannel extensions.

� All files (no multichannel). If you select this option, you can open
MPEG-1 as well as MPEG-2 low sampling frequency audio files without
the MPEG-2 extension information.

� All files (multichannel). If you select this option, you can open only
multichannel encoded files.

Opening Audio Stream
Files
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3. Select the appropriate file from the File name selection box and select OK.

4. If you have selected a file that was encoded using MPEG-2 extensions (for
example, LFE or multilingual extensions) and have selected either the
automatic or multichannel option in step 2, the following dialog box is
displayed.

5. Select the appropriate extension file, and then select OK. The First Level
and Main Characteristics view windows will be displayed.

Opening an Audio Elementary Stream from a Transport Stream. To extract and
analyze an elementary stream that is encoded in a transport stream file, use the
following procedure:

1. Confirm that you know the PID of the packets that contain the audio stream
of interest. If necessary, examine the transport stream first with the Tektronix
Deferred-Time Analyzer application.

2. Select Open from the File menu.

3. Use standard Windows NT techniques to select the appropriate file from the
Open dialog box.

4. Enter the PID of the packets that contain the audio stream.

NOTE. If you have the Tektronix MPEG Deferred-Time Analyzer, you can open
the MPEG Audio Stream Analyzer to analyze an audio elementary stream
directly from the Deferred-Time Analyzer. From the Hierarchic View, right-click
the audio icon and select Audio Stream Analyzer from the submenu.



Operating Basics

MPEG Audio Stream Analyzer User Manual 2–15

You can save complete audio stream files or specific parts of the audio stream.
You can also save decoded audio streams. (See Decoding Audio Stream Files on
page 2–18.)

NOTE. You can save audio stream files only when the First Level view is the
active view.

To save all or part of an audio stream file, use the following procedure:

1. Navigate to the First Level view window of the stream you want to save.

2. Select Save as from the File menu (or select the Save As button from the
Upper toolbar). The following dialog box is displayed.

3.  Using this dialog box, specify whether or not you want to save the complete
audio stream or just a specific part of the stream, by selecting one of the
following options:

� All the audio stream. This option is the default for storing encoded
streams and will save the complete audio stream. (If you select this
option, proceed to step 5.)

� From frame/length. This option allows you to save the specific portion
of the audio stream you indicate in the From frame and length text
boxes.

� From millisecond/duration. This option allows you to save the specific
portion of the audio stream you indicate in the From millisecond and
duration text boxes.

Saving Audio Stream Files
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4. If you chose to save a specific portion of the stream in step 3, perform one of
the following steps:

� If you chose From frame, indicate the starting frame in the From frame
text box and the number of frames you want to save in the length text
box.

� If you chose From milliseconds, indicate the starting millisecond in the
From millisecond text box and the number of milliseconds you want to
save in the duration text box.

NOTE. When the analyzer saves audio streams, it does so frame by frame.

5. Select the number of times you want to save the audio data in the
Repetitions text box, and then select OK. For each repetition greater than
one, the audio stream or the selected portion will be appended to the first
repetition.

If the stream you are saving uses MPEG-2 extensions (for example LFE or
multilingual extensions), proceed to step 6. Otherwise, proceed to step 8.

6. You are prompted to save the extension file first with the following dialog
box.

7. Select or type the name and extension for the MPEG-2 extension file in the
File name text box and select OK.

NOTE. It is easier to keep track of standard and extension files if you save both
files using a common file name and different file extensions (for instance,
testfile.ext and testfile.aud).
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8. You are prompted for the audio stream file name with the following dialog
box.

9. Select or type the file name and extension, and then select OK.

You can check the audio elementary streams for three separate types of errors:

� Syntactic. Syntactic errors indicate errors in the value(s) of a structure.

� Semantic. Semantic errors indicate errors in the MPEG structure.

� CRC. CRC errors indicate errors in transmission or decoding.

Syntactic Analysis. To perform a syntactic analysis, use the following procedure:

1. Navigate to the interpreted view of the element in the elementary stream that
you want to check.

2. Select Syntactic from the Analysis menu.

3. The analyzer performs a syntactic analysis of the element you have selected
and reports any errors in an error message window.

4. Double-click an error message and the interpreted view window containing
the syntax in error is displayed. The value of the field in error is displayed in
red.

You can perform syntactic analyses on all of the structures in the stream by
navigating to the First Level view window, and then selecting Syntactic from the
Analysis menu. See Syntactic Analysis on page 3–19 for more information.

Analyzing Audio Stream
Files
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Semantic Analysis. To perform a semantic analysis, use the following procedure:

1. Navigate to the First Level view.

2. Select Semantic from the Analysis menu.

3. The analyzer performs a semantic analysis of the entire stream and reports
any errors in an error message window.

4. Double-click an error message and the interpreted view of the element in
error is displayed.

You can perform semantic analyses only from the First Level view. See Semantic
Analysis on page 3–19 for more information.

CRC Error Check. To display the CRC errors, select the CRC icon from the First
Level view, and then select the Next error icon from the Edit toolbar. If CRC
errors are present, the next frame with an error is displayed with the CRC value
in red.

You can decode and save an audio stream and view the audio waveform using
the Wave Editor window (see Decoded View, beginning on page 2–11). As part
of the decoding process, the analyzer saves decoded streams as *.wav files.

The following list describes the options available for decoding and saving audio
stream data:

� All frames in the audio stream in stereo (if the stream contains stereo
information)

� Specific frames in stereo (if the stream contains stereo information)

� Only left or only right channels for all frames or for specific frames

See Decoding Audio Streams beginning on page 3–13 for complete procedures
on how to decode audio stream data. Use the following procedure to decode all
of the frames in the displayed audio stream:

1. Navigate to the either the First Level or the Channel view window.

2. Select Complete from the Decoding menu.

3. The MPEG Audio Stream Analyzer will begin decoding the stream and will
display the Save Decoded Sound Data dialog box.

Decoding Audio Stream
Files
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4. A default file name is displayed in the File name text box. If you want to use
that file name, select OK. Otherwise, type a file name and extension in the
File name text box and select OK.

5. After the analyzer finishes decoding the audio stream, the Wave Editor view
window is displayed. See Using the Wave Editor beginning on page 3–16 for
a discussion of the Wave Editor capabilities.

You can print any of the view windows displayed with the exception of the Main
Characteristics and Wave Editor view windows. To print the information
displayed in a view window, use the following procedure:

1. Set up the page layout by selecting Printer setup from the File menu. Make
appropriate selections for paper size and source, orientation, and margins
from the Page Setup dialog box.

2. Set up the printer connections by selecting the Printer command button, and
then making the appropriate printer and printer properties selections (see
your Windows documentation).

3. Return to the view window you want to print and select Print from the File
menu.

4. The Print dialog box is displayed. Make standard Windows Print selections
and print the contents of the active view window.

NOTE. You may need to change the font and page margins to print all of the
information displayed in some of the interpreted view windows.

Printing Audio Stream
Data
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To quit the MPEG Audio Stream Analyzer, select Exit from the File menu.

To close a window without exiting the analyzer application, use one of the
following techniques:

� To close an active view window, select the close button on the active view
window. Alternatively, select Close view from the Window menu.

� To close all windows, select Close all from the Window menu.

Quitting the MPEG Audio
Stream Analyzer
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Menu Selections
Table 2–6 describes each of the menu selections for the MPEG Audio Stream
Analyzer. The page references in parentheses indicate where you can find more
information about the selections for the menu.

Table 2–6: Menu selections 

Menu Selection Description

File Open Displays the Open dialog box from which you
identify the existing audio stream file you want to
view. Same as the Open button on the Upper
toolbar.

Save as Displays the Audio Stream Save dialog box from
which you indicate how much of the stream you
want to save. After you select OK, a standard Save
As dialog box is displayed. Same as the Save as
button on the Upper toolbar.

Print Displays a standard Print dialog box from which you
can print the active view window.

Printer setup Displays the Page Setup dialog box from which you
specify the paper size, orientation, and page
margins. The dialog box also provides access to
printer options.

Exit Quits the MPEG Audio Stream Analyzer.

Edit Next Displays the next item in the active view.

Previous Displays the previous item in the active view.

First Displays the first item in the active view.

Las Displays the last item in the active view.

Go to Displays the specified item in the active view.

Number of Items Calculates the number of items in the active view,
and then displays the number in the upper portion of
the active view window.

Next error Displays the next item in the active view with either
a CRC, syntax, or a semantic error.

Selection First level view Displays the First Level view for the audio stream
indicated in the title bar of the view window.

Main characteristics Displays the Main Characteristics view for the audio
stream indicated in the title bar of the view window.
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Table 2–6: Menu selections (cont.)

Menu DescriptionSelection

Analysis Syntactic Performs a Syntactic analysis on the audio stream
indicated in the title bar of the secondary window.

Semantic Performs a Semantic analysis on the audio stream
indicated in the title bar of the secondary window.

Automatic Performs both Syntactic and Semantic analyses on
the audio stream indicated in the title bar of the
secondary window.

Decoding Complete Displays the Save Decoded Data dialog box from
which you specify a file name for the decoded audio
stream. This selection is used to decode the entire
audio stream.

Partial Displays the Decoding dialog box from which you
select the start and stop frames of the audio stream
that you want to decode. After you select OK, the
Save as Decoded Data dialog box is displayed.

Options Base
(see page 3–21)

Displays the Base dialog box from which you set the
numeric base (decimal or hexadecimal) used for
various views.

Font
(see page 3–21)

Displays the Font dialog box from which you set the
font used for most of the views windows. (The
Binary and Hexadecimal view windows are not
affected by the font selection.)

Interpretation
(see page 3–22)

Displays the Interpreted view option dialog box from
which you can choose to display either the length or
the position of the structures in the interpreted
views.

Read configuration
(see page 3–22)

Displays the Read Configuration dialog box from
which you can load an existing configuration file into
the Audio Stream Analyzer.

Save configuration
(see page 3–22)

Displays the Save Configuration dialog box from
which you can save the current configuration into a
specified configuration file.

Set default configuration
(see page 3–22)

Loads the default configuration file into the Audio
Stream Analyzer.

Display in frames
(see page 3–22)

Changes the display unit of the Wave Editor to
frames.

Display in milliseconds
(see page 3–22)

Changes the display unit of the Wave Editor to
milliseconds.
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Table 2–6: Menu selections (cont.)

Menu DescriptionSelection

Window Cascade Displays the open view windows on top of one
another.

TIle Fits the open view windows to the application
window.

Arrange icons Arranges all minimized windows to the bottom of
the application window.

Close view Closes the selected view window.

Close all Closes all of the view windows.

Add view Displays a submenu from which you can choose to
add an identical view of the selected view or a
different view of the displayed information (for
instance, from an interpreted view you can choose
to display a binary or hexadecimal view of the frame
selected). Same as the Add View button on the
upper toolbar.

List of open view
windows

Selects the active view from the listed view windows
and brings the selected view to the front of the
display. All open views are listed, including any
minimized windows. A checkmark indicates the
current active view.

Help Contents Displays the MPEG 2 Audio Stream Analyzer Help
contents from which you can choose or search for a
specific help topic.

Using help Displays the Windows Help contents.

About MPEG Audio
Stream Analyzer

Displays version number and copyright information
about the MPEG Audio Stream Analyzer.
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Reference

Reference provides detailed information about the MPEG Audio Stream
Analyzer. This chapter is organized into the following sections:

� Interpreted Views describes each of the interpreted views accessible by
double-clicking the First Level view icons.

� Additional Views describes other views used by the analyzer to display and
interpret audio elementary stream data.

� Analyzing Audio Elementary Streams describes the types of audio elementary
stream analyses available using the MPEG Audio Stream Analyzer. This
section also describes how to decode audio streams and how to use the Wave
Editor view window.

� Options Menu Reference provides a reference for the Options menu
selections that allow you to configure the MPEG Audio Stream Analyzer.

Interpreted Views
Interpreted views provide a graphical user interface for examining MPEG audio
stream elements. The following section, Interpreted View Displays, describes the
types of displays used to interpret the audio stream elements and lists some
common interface features for each view type. It is followed by descriptions of
the interpreted views used by the analyzer (organized alphabetically).

The MPEG Audio Stream Analyzer uses graphical displays to help you interpret
the values of different MPEG-1 and MPEG-2 parameters. The types of displays
are differentiated in the way information is presented: one type of display is
tabular and  the other is linear. Both types of displays are interactive, making it
easy for you to determine what you are looking at when you examine the syntax.
These interactive characteristics are described in the following pages.

From all of the interpreted views, use the Edit toolbar to quickly navigate
through the frames of the audio stream file. (See Edit Toolbar on page 2–4.)
When you select the Next error button from the Edit toolbar (or Next error from
the Edit menu) the analyzer looks for syntactic errors and not semantic errors.
(To check an audio file for semantic errors, the First Level view must be the
active view window; the Edit toolbar is inactive from the First Level view.)
Select the Next Error command button while the CRC interpreted view is
displayed to automatically search for and display the next detected CRC error.

Interpreted View Displays
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Tabular displays. Tabular displays are those interpreted views that present the
extracted information in tabular format, like the Predictor Coefficient View
shown below: 

In addition to the information common to all interpreted views, tabular views
have common features of their own, as indicated in the following list:

� Information is presented in table format, with row and column headings and
cells for the actual information.

� Row and column headings provide access to descriptions of the displayed
syntax. To read the descriptions, double-click a row or column heading.

� Data displayed in the cells are one of two types: Actual values for the
various MPEG parameters or indices for a set of values from the standard.
To read the interpretation of the data in a specific cell, double-click the cell.
Red values indicate syntax errors.

The displayed parameter values can be shown in decimal or hexadecimal format.
To switch between the two, press the F2 function key. (You can choose Base
from the Options menu, and then make the selection from the dialog box.)

When you double-click a cell or heading in the tabular view the message box,
shown in the preceding illustration is displayed. The title bar of the message box
indicates the specific syntax displayed. You can position the box anywhere
within the view window by clicking and dragging the title bar of the box. Click
anywhere outside of the box to dismiss it.
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Some of the tabular displays also provide an additional tool bar, called the Group
toolbar, to help you navigate through groups of items in the syntax.

The Group toolbar is similar to the Edit toolbar, except the Go to next error and
Number of items buttons are not provided. The Edit toolbar is still available
from views that have a Group toolbar.

Linear displays. Linear displays are those interpreted views that present the
extracted information in a series of rectangles, like the Audio Header View
shown below.

In addition to the information common to all interpreted views, linear views have
common features of their own, as indicated in the following list:

� Large rectangles display parameter names. Shaded rectangles indicate more
critical MPEG parameters. Access descriptions of parameter by
double-clicking on the large rectangle representing the parameter.

The message box displayed can be moved anywhere within the view
window. To move the box, click and drag the title bar of the box. Click
anywhere outside of the box to dismiss it.
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� Small rectangles display the parameter value. Access the interpretation of the
displayed value by double-clicking on the small rectangle, as shown in the
following illustration. Click anywhere outside of the displayed message box
to dismiss it. Values displayed in red indicate an error in the parameter.

You can display parameter values in decimal or hexadecimal format. To
switch between the two, press the F2 function key. (Alternatively, select
Base from the Options menu, and then make the selection from the dialog
box that is displayed.)

Linear displays can also indicate the position or the length of the parameter in
the bitstream. When enabled, this information is displayed below the small
rectangles. You determine which type of information, if any, is displayed using
the following procedure:

1. Select Interpretation from the Options menu.

2. Select Position or Length from the resulting dialog box. Only one option
can be chosen at a time, or you can deselect both options.

� Position indicates the position in the bitstream of the first bit of the
parameter. Position is relative to the to the first bit in the displayed
syntax.

� Length is the length in bits of the parameter. For instance, the Layer
parameter is a 2-bit indicator, as shown in the preceding illustration.

When you start a new MPEG Audio Stream Analyzer session, the analyzer will
use the option selected the last time the analyzer was exited. The default
Interpretation option is to display neither length nor position information.
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Double-click the AAT icon from the First Level view to display a graphical
representation of the allocation table syntax. This view uses a tabular display.
(See page 3–2 for information about tabular displays.)

Double-click a row or column header to read a description of the syntax.
Double-click a cell to read an interpretation of the data for that cell.

Double-click the AD icon from the First Level view to display a graphical
representation of the ancillary data syntax as shown in the following illustration.
This view uses a modified linear display. (See page 3–3 for information about
linear displays.)

In the Ancillary Data interpreted view, the large rectangle looks three dimen-
sional and represents the data for the syntax.

Double-clicking the large rectangle displays either a hexadecimal or a binary
view of the data. (The format displayed depends on the frame from which you
accessed the Ancillary Data interpreted view.)

Double-clicking the small rectangle displays the message Bit value.

In order to use the Next error button on the Edit toolbar, display the bitstream
first by double-clicking on the large rectangle.

Allocation Table (AAT)

Ancillary Data (AD)
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Double-click the AH icon from the First Level view to display a graphical
representation of the audio header syntax for the indicated frame. This view uses
a linear display. (See page 3–3 for information about linear displays.)

Information about the following parameters is displayed in the audio header
interpreted view:

� Syncword � Private bit

� ID � Mode

� Layer � Mode extension

� Protection bit � Copyright

� Bit rate index � Original home

� Sampling frequency � Emphasis

� Padding bit

To read a description of a parameter, double-click the large rectangle with that
parameter name. To read an interpretation of a parameter value, double-click the
small rectangle below the parameter name.

Double-click the CRC icon from the First Level view to display a graphical
representation of the CRC error syntax. This view uses a linear display. (See
page 3–3 for information about linear displays.)

The small rectangle in the CRC error interpreted view displays the CRC value.
Red values indicate errors. Display other CRC errors by selecting the Next error
button on the Edit toolbar.

Double-click the DC icon from the First Level view to display a graphical
representation of the delay compensation syntax. This view uses a tabular
display. (See page 3–2 for information about tabular displays.)

Double-click a row or column header to read a description of the syntax.
Double-click a cell to read an interpretation of the data for that cell.

Double-click the LFEA icon from the First Level view to display a graphical
representation of the low frequency enhancement allocation syntax. This view
uses a linear display. (See page 3–3 for information about linear displays.)

Double-click the large rectangle to read a description of the syntax. Double-click
the small rectangle for an interpretation of the value.

Audio Header (AH)

Cyclic Redundancy Check
(CRC)

Delay Compensation (DC)

Low Frequency
Enhancement Allocation

(LFEA)
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Double-click the SPL icon (with the LFE sample title underneath) from the First
Level view to display the low frequency enhancement sample table syntax. This
view uses a tabular display. (See page 3–2 for information about tabular
displays.)

Double-click  a row or column header to read a description of the syntax. The
cells represent the value of the coded sample.

Double-click the LFSCF icon from the First Level view to display a graphical
representation of the low frequency scalefactor syntax. This view uses a linear
display. (See page 3–3 for information about linear displays.)

Double-click the large rectangle to read a description of the syntax. The small
rectangle is the scalefactor value.

Double-click the AAT icon (with the MC allocation title underneath it) from the
First Level view to display a graphical representation of the multichannel
allocation table syntax. This view uses a tabular display. (See page 3–2 for
information about tabular displays.)

Double-click  a row or column header to read a description of the syntax.
Double-click a cell to read an interpretation of the data for that cell.

Double-click the CSI icon from the First Level view to display a graphical
representation of the multichannel composite status information syntax. This
view uses a modified linear display. (See page 3–3 for information about linear
displays.)

Low Frequency
Enhancement Sample

Table (SPL)

Low Frequency
Scalefactor (LFSCF)

Multichannel Allocation
Table (AAT)

Multichannel Composite
Status Information

(MCCSI)
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The features for this interpreted view that are not standard are described in the
following list:

� Double-clicking the large Tc Allocation rectangle displays the transmission
channel allocation table, which is described on page 3–11.

� Double-clicking one of the other large three dimensional rectangles displays
a hexadecimal view of the bitstream for the parameter indicated.

� Double-clicking the small three dimensional rectangles displays the message
Number of data bits.

The rest of the elements are standard. Double-click a large rectangle to read a
description of the syntax. Double-click the small rectangles to display an
interpretation of the value for that parameter.

Double-click the CRC icon (with the MC error check title underneath) from the
First Level view to display a graphical representation of the multichannel CRC
error syntax. This view uses a linear display. (See page 3–3 for information
about linear displays.)

The small rectangle in the Multichannel CRC error interpreted view displays the
multichannel CRC value. Red values indicate errors. From this view you can
find other multichannel CRC errors by selecting the Next error button on the
Edit toolbar.

Double-click the MCH icon from the First Level view to display a graphical
representation of the multichannel header syntax. This view uses a linear display.
(See page 3–3 for information about linear displays.)

Information about the following parameters is displayed in the multichannel
header interpreted view:

� Extension bit stream present � De-matrix procedure

� Number of MPEG-1 compatible
ancillary data bytes (if present)

� Low frequency enhancement
channel present

� Center channel present � Multilingual sampling frequencies

� Surround channel present � Multilingual layer

� Number of multilingual channels � Copyright identification

� Audio mix � Copyright identification start

To read a description of a multichannel header parameter, double-click the large
rectangle with that parameter name. To read an interpretation of a parameter
value, double-click the small rectangle below the parameter name.

Multichannel Cyclic
Redundancy Check (CRC)

Multichannel Header
(MCH)
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Double-click the SPL icon (with the MC sample table title underneath) from the
First Level view to display a graphical representation of the multichannel sample
table syntax. This view uses a tabular display. (See page 3–2 for information
about tabular displays.)

Double-click  a row or column header to read a description of the syntax. The
cells represent the value of the coded sample. Use the Group toolbar to step
through the groups of the multichannel sample table syntax.

Double-click the SCFSI icon (with the MC SCFSI table title underneath) from
the First Level view to display a graphical representation of the multichannel
scalefactor selection information syntax. This view uses a tabular display. (See
page 3–2 for information about tabular displays.)

Double-click  a row or column header to read a description of the syntax.
Double-click a cell to read an interpretation of the data for that cell.

Double-click the SCF icon (with the MC scalefactor title underneath) from the
First Level view to display a graphical representation of the multichannel
scalefactor syntax. This view uses a modified tabular display. (See page 3–2 for
information about tabular displays.)

Double-click a row or column header to read a description of the syntax. The cell
data is multi-layered so that you can easily access the scalefactor values of the
different parts of the frame.

Multichannel  Sample
Table (SPL)

Multichannel Scalefactor
Selection Information

(SCFSI)

Multichannel Scalefactor
Table (SCF)
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Double-click the AAT icon (with the ML Allocation table title underneath) from
the First Level view to display a graphical representation of the multilingual
allocation table syntax. This view uses a tabular display. (See page 3–2 for
information about tabular displays.)

Double-click  a row or column header to read a description of the syntax.
Double-click a cell to read an interpretation of the data for that cell.

Double-click the SPL icon (with the ML sample table title underneath) from the
First Level view to display a graphical representation of the multilingual sample
table syntax. This view uses a tabular display. (See page 3–2 for information
about tabular displays.)

Double-click  a row or column header to read a description of the syntax. The
cells represent the value of the coded sample. Use the Group toolbar to step
through the groups of the multilingual sample table syntax.

Double-click the SCFSI icon (with the ML SCFSI table title underneath) from
the First Level view to display a representation of the multilingual SCFSI
syntax. This view uses a tabular display. (See page 3–2 for information about
tabular displays.)

Double-click  a row or column header to read a description of the syntax.
Double-click a cell to read an interpretation of the data for that cell.

Double-click the SCF icon (with the ML scalefactor title underneath) from the
First Level view to display a graphical representation of the multilingual
scalefactor syntax. This view uses a modified tabular display. (See page 3–2 for
information about tabular displays.) See the multichannel scalefactor table
display figure on page 3–9.

Double-click a row or column header to read a description of the syntax. The cell
data is multi-layered so that you can easily access the scalefactor values of the
different parts of the frame.

Double-click the PC icon from the First Level view to display a graphical
representation of the predictor coefficient syntax. This view uses a tabular
display. (See page 3–2 for information about tabular displays.)

Double-click  a row or column header to read a description of the syntax. The
cell data represent the actual predictor coefficients. Use the Group toolbar to step
through the groups of the predictor coefficient syntax.

Multilingual Allocation
Table (AAT)

Multilingual Sample Table
(SPL)

Multilingual Scalefactor
Selection Information

(SCFSI)

Multilingual Scalefactor
Table (SCF)

Predictor Coefficient (PC)
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Double-click the SPL icon from the First Level view to display a graphical
representation of the sample table syntax. This view uses a tabular display. (See
page 3–2 for information about tabular displays.)

Double-click  a row or column header to read a description of the syntax. The
cells represent the value of the coded sample. Use the Group toolbar to step
through the groups of the multilingual sample table syntax.

Double-click the SCFSI icon from the First Level view to display a graphical
representation of the scalefactor selection information syntax. This view uses a
tabular display. (See page 3–2 for information about tabular displays.)

Double-click  a row or column header to read a description of the syntax.
Double-click a cell to read an interpretation of the data for that cell.

Double-click the SCF icon from the First Level view to display a graphical
representation of the scalefactor syntax. This view uses a modified tabular
display. (See page 3–2 for information about tabular displays.) See the figure
showing the multichannel scalefactor table display on page 3–9 to see a
representation of the Scalefactor Table interpreted view window.

Double-click a row or column header to read a description of the syntax. The cell
data is multi-layered so that you can easily access the scalefactor values of the
different parts of the frame.

Double-click the TC Allocation rectangle from the Multichannel Composite
Status Information interpreted view to display a graphical representation of the
transmission channel syntax. This view uses a tabular display. (See page 3–2
for information about tabular displays.)

Double-click  a row or column header to read a description of the syntax.
Double-click a cell to read an interpretation of the data for that cell.

Sample Table (SPL)

Scalefactor Selection
Information (SCFSI)

Scalefactor Table (SCF)

Transmission Channel
Allocation (TC)
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Additional Views
Interpreted view windows display different syntax of MPEG audio bitstreams.
The view windows described in this section offer alternative ways of viewing the
bitstream.

� The Binary and Hexadecimal view windows display low-level views of the
bitstream.

� The Channel view window displays the channel distribution for an audio
elementary stream.

� The Wave Editor view window displays the analog waveform of a decoded
audio stream.

The Binary and Hexadecimal view windows display the audio bitstream for the
MPEG syntax indicated in the top line of the view window (the interpreted view
from which you accessed the binary or hexadecimal view).

Display the Binary or Hexadecimal views using one of the following techniques:

� From an interpreted view, click the Add view button, and then select either
Binary or Hexadecimal from the submenu.

� From an interpreted view, select Add view from the Window menu, and then
select either Binary or Hexadecimal from the submenu.

The Edit toolbar is available from either of these views, so you can step through
the binary or hexadecimal views for the other frames of the syntax you are
viewing. (See Edit Toolbar on page 2–4.) When you select the Next error button
(or Next error from the Edit menu), the analyzer looks for syntactic errors and
not semantic errors.

Binary and Hexadecimal
Views
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The Channel view window displays the channel distribution for the audio stream
as shown in the following illustration. The Channel view provides the common
view window elements as described in Common View Window Elements
beginning on page 2–5.

The icons are interactive. Right-click a left or right channel icon to display a
submenu from which you can choose to decode the audio stream. You can
decode the audio stream in stereo if the audio stream contains stereo information.
If not, the analyzer will decode the audio stream as a single channel. To decode
audio stream files, use the procedure described in the next section, Decoding
Audio Streams.

Immediately after the audio stream has been decoded and saved as a *.wav file,
the Wave Editor view window is displayed. See Wave Editor beginning on page
3–16 for information about the Wave Editor view window.

Decoding Audio Streams. Decode all or part of an audio stream using the
following procedure:

1. Navigate to the First Level or Channel view window.

2. Select one of the following options from the Decoding menu:

� Complete. Use this option to decode all of the audio frames in the audio
stream. (If stereo information is present, the *.wav file is decoded in
stereo.)

� Partial. Use this option to decode the specific frames of the audio
stream. (If stereo information is present, the *.wav file is decoded in
stereo.)

Channel View
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3. If you selected Partial in step 2, specify a start and stop frame from the
displayed dialog box, and then select OK. The frames you specify will make
up the new *.wav file.

4. Select or type the name and extension for the decoded file in the Save
Decoded Sound Data dialog box, and then click OK. The analyzer saves
decoded audio data as *.wav files.

5. While the audio stream is being decoded, the view window displays a
message below the first line, indicating that the decoding process is running.

After the audio stream is decoded and written to the file name you have chosen,
the Wave Editor window is displayed (see page 3–16).
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To decode specific channels of an audio stream, use the following procedure:

1. Navigate to the Channel view window.

a. Navigate to the First Level view for the audio stream you want to
decode.

b. Select Add View from the Window menu, and then select Channel
View from the submenu.

2. Right-click the Left or Right Channel icon and select Decode from the
submenu (if you select Stereo that you will save both the right and the left
channel information to the *.wav file).

3. The dialog box shown below is displayed. Indicate which frames you want
to decode in the text boxes provided, and then select OK. (The default
option is the complete audio stream.)

4. Select or type the name for the decoded file in the Save Decoded Sound Data
dialog box.

After you select OK, the audio stream is decoded and written to the file name
you chose in step 4. After the file has been decoded, the Wave Editor window is
displayed (see page 3–16).

NOTE. The MPEG Audio Stream Analyzer decodes only to MPEG-1 standards:
single channel and stereo. Multichannel decoding is not supported.
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You can display analog waveforms of decoded audio streams, play decoded
audio files, and save decoded audio files as *.wav files, using the Wave Editor
view window. To listen to audio files, you must have a sound card installed on
your computer.

The Wave Editor view window is displayed immediately after an audio stream is
decoded. Procedures for decoding audio streams are provided in Decoding Audio
Streams beginning on page 3–13. The following section, Using the Wave Editor,
describes how to use the Wave Editor view window.

Using the Wave Editor. The Wave Editor view window graphically displays the
analog waveform for the decoded audio stream.

NOTE. The Wave Editor view window displays only one waveform at a time. If
the audio stream you have decoded is a stereo or multichannel stream, the
analyzer defaults to displaying only the left channel waveform.

The following list describes the elements of the Wave Editor view window.
Table 3–1 on page 3–17 describes the Wave Editor toolbar elements.

� The title bar displays the decoded file name and location.

� The Wave Editor toolbar displays the controls you use to play, save, and
select portions of the waveform.

� The middle and bottom sections display the analog waveform.

Wave Editor View
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The bottom section displays the waveform compressed to fit the width of the
view window. If Display in frames is checked in the Options menu, the
horizontal unit of measurement is audio stream frames. If Display in
milliseconds is checked, the unit of measurement is milliseconds.

� The eighth note indicates the position in the sound file as the decoded
audio stream is played.

� The total time (in seconds) and length (in frames) of the decoded audio
file is indicated in the lower right of the view window.

Table 3–1: Wave Editor toolbar elements  

Element Name Description

Play Starts playing the decoded audio file.

Unless you have selected a portion of the waveform, the
complete waveform is played when you select this
command button. If a portion of the waveform is
selected, only the selected portion of the sound file is
played.

Stop Stops playing the decoded audio file.

Pause/Resume Pauses and resumes playing the decoded audio file.

Save As Saves the decoded audio file.

Unless you have selected a portion of the waveform, the
complete waveform is saved when you select this
command button. If a portion of the waveform is
selected, only the selected portion of the sound file is
saved.

Position Sets the position of the cursor in the bottom part of the
Wave Editor view window.

Change the position of the cursor by selecting the up
and down buttons, or by clicking in the bottom waveform
display.
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Table 3–1: Wave Editor toolbar elements  (cont.)

Element DescriptionName

Selection Selects a portion of the audio file. The selected portion
of the audio file starts at the cursor position.

Change the selected portion of the waveform by
selecting the up and down buttons, or by clicking and
dragging in the bottom waveform display.

The selected portion of the waveform determines which
part of the audio file will be played and saved.

Zoom Sets a horizontal zoom factor for the upper waveform
display.

Change the zoom factor by selecting the up and down
buttons, or by moving the scroll bar.

Initially, the waveform is displayed at the highest zoom
factor.

Display Sets the unit of measurement used in the Wave Editor
view window.

Set the unit used for the Wave Editor by selecting either
Display in frames or Display in milliseconds from the
Options menu. The current unit of increment has a
check mark next to it in the Options menu.

Analyzing Audio Elementary Streams
The MPEG Audio Stream Analyzer can check for the following types of errors:

� Syntax errors, which indicate errors in the values of the MPEG structures.

� Semantic errors, which indicate errors in the structure of the audio stream.

� CRC errors, which indicate errors in transmitting or decoding the audio
stream.

Procedures for performing the analyses that check for these types of errors are
described in this section.

NOTE. The MPEG Audio Stream Analyzer does not analyze all MPEG audio
elementary stream structures. Only those structures displayed in one the
interpreted view windows are checked for syntax, semantic, and/or CRC errors.
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You can perform syntactic analyses on a specific MPEG structure, or on the
entire audio stream, using the following procedure:

1. Display the interpreted view window of the structure you want to check. (If
you want to check all of the structures at once, perform the syntax analyses
from the First Level view.)

2. Select Syntactic from the Analysis menu. The frame number in the top line
of the interpreted view cycles through the frames of the audio stream to
indicate that the analysis is being performed.

3. If the analysis finds errors in the audio stream syntax, the following message
box is displayed. Each line represents an error at the stream location
indicated.

4. To view the error, double-click a message line. The syntax in error is
displayed, and value in error is usually shown in red.

Semantic analyses can be performed only when the First Level view is the active
view window. Use the following procedure to perform a semantic analysis of the
audio stream.

1. Ensure that the First Level view is the active view window.

2. Select Semantic from the Analysis menu. The frame number in the top line
of the interpreted view cycles through the frames of the audio stream to
indicate that the analysis is being performed.

3. If the analysis finds semantic errors in the audio stream, the following error
message box is displayed. Each line represents an error at the stream location
indicated.

4. To view the error, double-click a message line. For semantic analyses, the
errors are not indicated in red.

Syntactic Analysis

Semantic Analysis
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The Automatic analysis selection from the Analysis menu allows you to
perform both syntactic and semantic analyses without having to select both
individually. The error reporting display mechanisms are similar to those
described for syntactic and semantic analyses except that the dialog box shown
below is displayed as the file is being analyzed for errors.

To perform both a syntactic and semantic analysis on the active audio stream,
use the following procedure:

1. Ensure that the First Level view for the audio stream that you want to
analyze is the active view window.

2. Select Automatic from the Analysis menu.

3. A syntactic analysis is carried out first followed the semantic analysis. To
stop the analysis, press the button at the bottom of the message window.

The Result column indicates the results of the analyses. If an error is found
the word Errors is displayed in red in either the Syntactic or Semantic row.

4. Double-click the word Errors, and message windows identical to the
syntactic and semantic analyses error message windows are displayed.

The CRC value is automatically checked as the audio stream is displayed in the
MPEG Audio Stream Analyzer. For information about how to find CRC errors,
see Cyclic Redundancy Check (CRC) on page 3–6.

Automatic Analysis

CRC Error Check
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Options Menu Reference
Use the selections from the Options menu to configure how the current MPEG
Audio Stream Analyzer session displays information. You can also save and load
configuration files using the Option menu selections.

NOTE. The Options menu selections apply to the analyzer and not the audio
streams displayed. Consequently, when an audio stream is opened, the informa-
tion displayed reflects the current analyzer configuration. Furthermore, when
beginning a new session, the analyzer loads the configuration options selected
the last time it was was exited

Use this menu selection to determine how the interpreted views display the audio
elementary stream data. The MPEG Audio Stream Analyzer can display the data
in either decimal or hexadecimal base. The default is decimal base.

1. Select Base from the Options menu.

2. From the displayed Base dialog box, select Decimal or Hexadecimal.

When you start a new MPEG Audio Stream Analyzer session, the analyzer uses
the base displayed the last time the application was exited.

To switch between decimal and hexadecimal base, press the F2 function key.

NOTE. Even though you can display information in either decimal or hexade-
cimal, you can enter values only in decimal base.

Use this menu selection to determine which font is used to display information
in some of the analyzer view windows. (The Wave Editor, Main Characteristics,
and the Binary and Hexadecimal view windows use a fixed font and are not
affected by the font selection.)

When you start a new MPEG Audio Stream Analyzer session, the analyzer uses
the font displayed the last time the application was exited.

Base

Font
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This menu selection allows you to display the length or the position of a field in
the bitstream. This information is only available in the linear display view
windows.

1. Select Interpretation from the Options menu.

2. Select Position or Length from the Interpretation dialog box. You can either
deselect both options, or select one of the options.

� Position indicates the position in the bitstream of the first bit of the
field. Position is relative to the first bit in the displayed structure.

� Length is the length of the field in bits.

The default setting is to display no position or length information.

The following Options menu selections allow you to save and load configuration
files.

Read configuration. Use this menu selection to load a previously saved configura-
tion file (an .acf file) into the current analyzer session.

Save configuration. Use this menu selection to save the current analyzer settings
to a configuration file (an .acf file) that you can transfer to another system or
load at a later time.

Set default configuration. Use this menu selection to revert the current Base, Font,
and Interpretation selections to the default settings.

The following Options menu selections allow you to determine the unit of
measurement used in the Wave Editor view. The current option is indicated by a
checkmark next to the name of the option.

Display in frames. Use this menu selection to enable the audio frame unit of
measurement for the Wave Editor. When this option is selected, the Wave Editor
toolbar elements and displays use audio frames as a unit of measurement, and the
item has a checkmark next to it in the Options menu.

Display in milliseconds. Use this menu selection to enable the millisecond/second
unit of measurement for the Wave Editor. When this option is selected, the Wave
Editor toolbar elements and displays use millisecond as a unit of measurement,
and the item has a checkmark next to it in the Options menu. Total time, in the
lower right-corner of the view window, is displayed in seconds.

Interpretation

Configuration Files

Wave Editor Configuration
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Index
A
Add view

binary or hexadecimal, 3–12
channel view, 3–15
first level, 2–8
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menu selection, 2–23
options, 2–12
upper toolbar command button, 2–3

Address, Tektronix, vi
Allocation table, 3–5
Analyzing audio streams

audio layers, 1–1
overview, 2–17
procedures for, 3–18
types of analyses, 1–2

Ancillary data, 3–5
Application window, 2–2
Audio header, 3–6
Audio Sound Saving, dialog box, 2–15
Audio streams

analyzing, 2–17
decoding, 2–18, 3–13
opening, 2–13
saving, 2–15
viewing, 2–7

Automatic
analyses procedure, 3–20
menu selection, 2–22

B
Base

menu selection, 2–22
procedure for changing, 3–21

Basic Operations, 2–13
Binary view, 2–10, 3–12
Buttons

Edit toolbar, 2–4
Group toolbar, 3–3
Upper toolbar, 2–3
Wave Editor toolbar, 3–17

C
Cell data, tabular display windows, 3–2
Channel view, 3–13

overview, 2–10
Closing windows, 2–20
Column headings, tabular display windows, 3–2
Common view window elements, 2–5
Complete

decoding stream procedure, 3–13
menu selection, 2–22

Configuration, read, save, and set default, 3–22
Contacting Tektronix, vi
CRC error check, 2–18

procedure, 3–20
view window, 3–6

D
Decimal and Hexadecimal base, 3–21
Decoded view of audio streams, Wave Editor, 2–11
Decoding an audio stream, 2–18, 3–13
Delay compensation, 3–6
Display in frames, menu selection, 2–22
Display in milliseconds, menu selection, 2–22
Displays

linear, 3–3
tabular, 3–2

E
Edit toolbar, 2–4
Elementary stream files, opening, 2–14
Error message window

semantic analysis, 3–20
syntactic analysis, 3–19

Exit, menu selection, 2–21
Exiting the application, 2–20
Extension file

Open dialog box, 2–14
Save as dialog box, 2–16
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F
Fields, interpreting position or length, 3–22
First, edit toolbar command button, 2–4
First level view

overview, 2–8
upper toolbar command button, 2–3

First time operation, 1–2
First-time operation, v
Font

menu selection, 2–22
setting, 3–21

Frame number indicator, 2–6
Functional overview, 2–2

G
Go to

edit toolbar command button, 2–4
menu selection quick reference, 2–21

Group toolbar, 3–3

H
Hardware, installation, v
Hexadecimal view, 2–10

I
Icons

Audio Stream Analyzer, 2–1
Channel view, 2–10
Edit toolbar, 2–4
First level view, 2–9
Group toolbar, 3–3
Upper toolbar, 2–3
Wave Editor toolbar, 3–17

Installation, hardware, v
Interface description, 2–5
Interpretation

menu selection, 2–22
position or length, 3–22

Interpreted Views
Allocation table (AAT), 3–5
Ancillary data, 3–5
Audio header, 3–6
common elements for linear displays, 3–3
common elements for tabular displays, 3–2
Cyclic Redundancy Check (CRC), 3–6

Delay compensation, 3–6
icons, 2–9
Low frequency enhancement allocation, 3–6
Low frequency enhancement SPL, 3–7
Low frequency SCF, 3–7
MCH, 3–8
Multichannel AAT, 3–7
Multichannel Composite Status Information, 3–7
Multichannel CRC, 3–8
Multichannel SCF, 3–9
Multichannel SCFSI, 3–9
Multichannel SPL, 3–9
Multilingual AAT, 3–10
Multilingual SCF, 3–10
Multilingual SCFSI, 3–10
Multilingual SPL, 3–10
Predictor coefficient, 3–10
Sample table (SPL), 3–11
Scalefactor selection information (SCFSI), 3–11
Scalefactor table (SCF), 3–11
Transmission channel allocation (TC), 3–11
types of displays used for, 3–1

L
Last, edit toolbar command button, 2–4
Length, interpreting field, 3–22
List files of type, Open dialog box selection, 2–13
List of open view windows, 2–23
Low frequency, scalefactor, 3–7
Low frequency enhancement

allocation, 3–6
scalefactor, 3–7

Lower toolbar, 2–4

M
Main characteristics view

overview, 2–7
upper toolbar command button, 2–3

Menu bar, 2–3
Menu Selections, quick reference to, 2–21
MPEG fields

described in linear display types, 3–3
described in tabular displays, 3–2

MPEG parameters
displayed in tabular view windows, 3–2
displayed in the audio header view window, 3–6
displayed in the mulitchannel header view window,

3–8
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MPEG structures, displayed as interpreted views, 1–1
Multichannel

allocation table, 3–7
composite status information, 3–7
CRC error check, 3–8
header, 3–8
sample table, 3–9
scalefactor selection information, 3–9
scalefactor table, 3–9

Multichannel audio streams
opening, 2–14
saving, 2–15

Multilingual
allocation, 3–10
sample table, 3–10
scalefactor selection information, 3–10
scalefactor table, 3–10

N
Next, edit toolbar command button, 2–4
Next error, edit toolbar command button, 2–4
Number of items, edit toolbar command button, 2–4

O
Online help, Contents menu selection, 2–23
Open, upper toolbar command button, 2–3
Opening an audio stream file, 2–13

P
Parameter values, displayed in linear view windows,

3–3
Partial

decoding stream procedure, 3–13
menu selection, 2–22

Phone number, Tektronix, vi
Position, interpreting field, 3–22
Position indicator, 2–6
Predictor coefficient, 3–10

group toolbar, 3–3
Previous, edit toolbar command button, 2–4
Print, 2–19
Product limitations, 1–2
Product support, contact information, vi

Q
Quitting the application, 2–20

R
Read configuration, menu selection, 2–22
Red parameter values

in CRC field, 3–6
in linear displays, 3–4
in tabular displays, 3–2

Row headings, tabular display windows, 3–2

S
Sample table, 3–11

group toolbar, 3–3
Save as

extension file dialog box, 2–16
saving audio streams, 2–15
upper toolbar command button, 2–3

Save configuration, menu selection, 2–22
Save Decoded Sound Data, dialog box, 2–19
Scalefactor, low frequency, 3–7
Scalefactor selection information, 3–11
Scalefactor table, 3–11
Semantic analysis

basic procedure, 2–18
error message window, 3–20
procedure, 3–19

Service information, vi
Service support, contact information, vi
Set default configuration, menu selection, 2–22
Setup, hardware, v
Shaded rectangles, in linear displays, 3–3
Software version, v
Specifications, v
Start application, 2–1
Status bar, 2–3
Streams

analyzing, 2–17
decoding, 2–18
opening, 2–13
saving, 2–15
viewing, 2–7

Syntactic analysis
basic procedure, 2–17
error message window, 3–19
procedure, 3–19
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T
Tektronix MPEG Test System, 1–2
Time indicator, 2–6
Title bar, 2–2
Toolbar, edit, 2–4
Transmission channel allocation, 3–11
Transport streams, opening an audio stream from, 2–14

U
Upper toolbar, 2–3
URL, Tektronix, vi

V
Version, software, v
View window, common elements, 2–5
Viewing audio files, overview, 2–7
Views

adding, 2–12
Channel view, 3–13
Interpreted views, 3–1
overview of linear displays, 3–3

overview of tabular displays, 3–2
Wave Editor view, 3–16

W
Wave Editor, 2–11

toolbar, 3–17
using, 3–16
view window, 3–16

Web site address, Tektronix, vi
Window, application, 2–2
Windows

automatic analyses, 3–20
Binary and Hexadecimal view, 3–12
Channel view, 3–13
common elements, 2–5
error message, 3–19
First level view, 2–8
Interpreted view, 3–1
linear display type, 3–3
Main characteristics view, 2–7
tabular display type, 3–2
Wave Editor view, 3–16
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