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WARRANTY

Tektronix warrants that the media on which this software product is furnished and the encoding of the programs on the
media will be free from defects in materials and workmanship for a period of three (3) months from the date of shipment.
If a medium or encoding proves defective during the warranty period, Tektronix will provide a replacement in exchange
for the defective medium. Except as to the media on which this software product is furnished, this software product is
provided “as is” without warranty of any kind, either express or implied. Tektronix does not warrant that the functions
contained in this software product will meet Customer’s requirements or that the operation of the programs will be
uninterrupted or error-free.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of the
warranty period. If Tektronix is unable to provide a replacement that is free from defects in materials and workmanship
within a reasonable time thereafter, Customer may terminate the license for this software product and return this software
product and any associated materials for credit or refund.

THIS WARRANTY IS GIVEN BY TEKTRONIX IN LIEU OF ANY OTHER WARRANTIES, EXPRESS OR
IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. TEKTRONIX’ RESPONSIBILITY TO
REPLACE DEFECTIVE MEDIA OR REFUND CUSTOMER’S PAYMENT IS THE SOLE AND EXCLUSIVE
REMEDY PROVIDED TO THE CUSTOMER FOR BREACH OF THIS WARRANTY. TEKTRONIX AND ITS
VENDORS WILL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL
DAMAGES IRRESPECTIVE OF WHETHER TEKTRONIX OR THE VENDOR HAS ADVANCE NOTICE OF
THE POSSIBILITY OF SUCH DAMAGES.
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Preface

This manual documents the MTS300 Dolby Digital Audio Stream Analyzer
application. If you purchased an MTS 300 Series test system and are looking for
information about installation,  first-time operation, or specifications, refer to the
MTS 300 MPEG Test System Hardware and Software Installation Technical
Reference, Tektronix part number 071-0667-XX.

For the latest information about MTS 300 Series Software features and bugs,
refer to the MPEG Test System Software Version 1.0 Read This First document,
Tektronix part number 071-0666-XX, that accompanied your test system,
software product, or upgrade.

For information about the Windows NT Workstation operating system, refer to
the Windows NT online help.

Wherever possible, this manual uses symbols and terminology consistent with
Microsoft Windows and MPEG-2 standards. Refer to your Windows documenta-
tion for definitions and explanations of Windows terminology.

Manual Structure
This manual is divided into the following sections:

Getting Started. The Getting Started section contains the information that you
need to get the Dolby Digital Audio Stream Analyzer up and running.

Operating Basics. The Operating Basics section contains a functional overview of
the product and basic user interface operating instructions.

Reference. The Reference section contains in-depth descriptions of the analyzer
capabilities, the software interface, and configuration options.

Index. Alphabetical listing of the topics covered in this manual.
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Software Version
Table i lists the MTS 300 Series MPEG Test System application version number
supported by this manual. To verify an application version number, select Help
in the application menu bar; then select About from the Help menu.

Table i: MTS 300 Series MPEG Test System (V5.0) supported applications 

Application Version supported

Dolby Digital Analyzer 1.31 and above

Contacting Tektronix

Product
Support

For questions about using Tektronix measurement products, call
toll free in North America:
1-800-833-9200
6:00 a.m. – 5:00 p.m. Pacific time

Or contact us by e-mail:
tm_app_supp@tek.com

For product support outside of North America, contact your
local Tektronix distributor or sales office.

Service
support

Tektronix offers a range of services, including Extended
Warranty Repair and Calibration services. Contact your local
Tektronix distributor or sales office for details.

For a listing of worldwide service centers, visit our web site.

Toll-free
Number

In North America:
1-800-833-9200
An operator can direct your call.

Postal 
Address

Tektronix, Inc.
Department or name (if known)
P.O. Box 500
Beaverton, OR 97077
USA

Web site www.tektronix.com
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Getting Started

The Dolby Digital Audio Stream Analyzer enables you to analyze elementary
audio stream files encoded to the AC-3 standard. You can use this tool to analyze
stream samples or whole records stored in files. Developers of AC-3 encoders or
decoders can use this tool in their test and development phase.

Product Description
You can perform the following tasks with the Dolby Digital Audio Stream
Analyzer:

� Display the structure of AC-3 streams to relate the streams to the AC-3
standard.

� Detect nonstandard streams and evaluate the cause of an audio problem.

� Analyze streams at different levels.

� Perform the following analyses: Syntactic (structural), Semantic (coherence
between all components), and CRC (error checking). 

� Extract audio elementary streams from transport stream files.

� Save all or part of an AC-3 audio stream as an *.AC3 file.

� Generate graphic views that provide high-level information about the
characteristics and structure of the stream.

� Generate interpreted views that display field values within the stream.

The Dolby Digital Audio Stream Analyzer can display the following audio
elementary streams formats:

� .AC3 files – Audio stream files encoded in accordance with the Advanced
Television Systems Committee (ATSC) Digital Audio Compression (AC-3)
Standard (December 20, 1995).

� .PRG files – MPEG-2 program stream files used in the DVD standard. You
must enter the SID (stream identifier) of the AC-3 stream.

� .VOB Files – DVD video object. Streams of this type can contain up to eight
AC-3 files. You must provide a stream ID (default 189) and a substream ID
starting at 128.

Audio Stream File Types
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� .TRP files – Raw MPEG-2 transport stream files used in the U.S. ATSC
Digital Television broadcasting system. You must enter the PID of the AC-3
stream.

Installing Software
The Dolby Digital Audio Stream Analyzer is part of the MTS 300 Test System
suite of hardware and software components used to create, generate, acquire, and
analyze MPEG, DVB, and ATSC transport and program streams.

If you purchased an MTS 300 test system and need system-related information or
specifications, refer to the MTS 300 Series Hardware Installation and Specifica-
tions Technical Reference, Tektronix part number 071-0667-XX.

If you purchased the Dolby Digital Audio Stream Analyzer as an upgrade to an
MTS 300 test system and need software installation instructions, refer to the
upgrade instructions, Tektronix part number 075-0630-XX.

If you purchased the Dolby Digital Audio Stream Analyzer to install on a
personal computer and need software installation instructions, refer to the
software installation manual that accompanied the option, Tektronix part number
075-0630-XX.

Before you can operate the Dolby Digital Audio Stream Analyzer you must enter
the correct password for your software configuration. Use the procedure in your
installation manual to enter the general password.

On MTS 300 Test Systems

On Personal Computers

Entering the General
(License) Password
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Starting the Analyzer

To start the Dolby Digital Audio Stream Analyzer, log on to your MTS 300 test
system or personal computer and start Windows NT.

Locate the Tektronix MPEG Test System icon on the Windows NT desktop. If it
is not already open, double-click the folder icon to open the program group
window.

Double-click the Dolby Digital Analyzer icon in the program group window.

Exiting the Analyzer
To quit the Dolby Digital Audio Stream Analyzer, select Exit from the File
menu, or click the close box in the upper-right corner of the application window.

Application
Close box

Active view
Close box

The current analyzer configuration is preserved and used the next time you start
the application.

To close an active view window without exiting the analyzer application, select
the close button on the active view window, or select Close view from the
analyzer Window menu.

To close all windows without exiting the analyzer application, select Close all
from the analyzer Window menu.
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Opening an Audio Stream File
To open an audio stream file, do the following:

1. Select Open from the File menu. The Open dialog box displays.

The default selection from the List files of type drop down selection box is
Dolby AC-3 Stream (.AC3). To display a file that uses another suffix (see
Audio Stream File Types on page 1–1), select the appropriate suffix from
the List files of type selection box.

2. Select the AC-3 audio file you want to open.

3. Click OK. The Frame view and the Main Characteristics view for the audio
stream open.
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Operating Basics

In this section you will find basic operating information, explanations of the
views used to display audio streams, and menu descriptions. For basic informa-
tion on the Windows operating system, such as minimizing windows or using the
scroll bars, refer to your Windows documentation.

Functional Overview
The Dolby Digital Audio Stream Analyzer uses two window types to display
audio streams: the Application window and the View window.

The Application window provides the main operating environment for the
analyzer. The following figure shows the basic features of the Application
window.

TItle Bar
Menu Bar

Upper Toolbar

Status Bar
Edit Toolbar

Application Window
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Title Bar. In the Application window, the Title Bar displays the application name
on the left and provides standard Windows window controls on the right.

Menu Bar. The Menu Bar provides access to commands that control analyzer
display, analysis, and appearance. Using Menus, beginning on page 2–18,
describes the menu selections.

Upper Toolbar. The Upper Toolbar provides shortcut buttons to some commonly
used menu selections. Move the mouse over an Upper Toolbar button to display
the button name.

Button Name Description

Open Displays the Open dialog box.

Save as Displays the Save as dialog box.

Frame view Displays the Frame view window for the active audio stream.

Add view Displays a submenu. You must specify a view to display.

Main character-
istics view

Displays the Main Characteristics window for the active audio
stream.

Edit Toolbar. The Edit Toolbar buttons allow you to move through the items of
the current view and to view the errors in an audio stream file. The toolbar
buttons are equivalent to Edit menu selections.

Button Name Description

First Displays the first item in the active view.

Previous Displays the previous item in the active view.

Go to Displays a dialog box to enter details about the active view you
want to display.

Next Displays the next item in the active view.

Last Displays the last item in the active view.

Number of
Items

Counts the number of items in the element and displays the
number at the top of the Interpreted view.

Next error Displays the next item in the audio stream file containing an error.
This button is active when the question mark is red.

Status Bar. The Status Bar, which is located at the bottom of the analyzer
window, describes a menu selection as you highlight the selection.
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The View window displays the structure of an audio stream file within the
Application window. The following figure shows the basic features of the View
window.

View
Window

Title Bar

Top Line

Title Bar. In addition to standard window controls, the View window Title Bar
provides the following information about the display:

� View type.

� Name of the displayed audio stream file (or the transport stream from which
the audio stream was extracted). If you maximize the View window, this
information displays in the Title Bar of the Application window.

View Window
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Top Line. The top line provides the following information for AC-3 files. (This
information is not available for raw AC-3 files):

� View type.

� Frame number of the displayed element, relative to the first synchronized
frame. The number of the first synchronized frame is one.

� Position of the displayed element, indicated in bytes (b) and relative to the
first byte of the first synchronized frame. The position of the first synchro-
nized frame is zero.

� Time stamp of the displayed element, indicated in seconds (s) and relative to
the first byte of the first synchronized frame. The time of the first synchro-
nized frame is zero.

Analyzer Views
This section explains the displays the analyzer uses to view data. For more
complete information about these views, see the Reference section beginning on
page 3–1.

The Main Characteristics view window displays when you open an audio stream
file. You can also access this view by selecting the Main characteristics button
from the Upper Toolbar or by selecting Main characteristics from the View
menu. You can open a Main Characteristics view from any Frame view window.
You cannot access this view from a Binary or Hexadecimal view.

Graphical Channel
Indicator

The Main Characteristics view displays the main properties of the opened
stream. This view has a Graphical Channel Indicator in the upper-right corner of
the window.

Main Characteristics
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The Main Characteristics view provides quick access to the following informa-
tion about the audio stream:

� AC-3 Version number. Lists the version of the displayed signal.

� Sampling Frequency. Displays the sampling frequency of the displayed
signal.

� Type of Service. Displays the type of service of the displayed signal.

� Audio Coding Mode. The first displayed number represents the number of
left, front, and right channels. The second number represents the number of
surround channels.

� Bitrate. Displays the bitrate of the displayed signal.

� Center Channel. The analyzer displays yes or none to indicate whether a
center channel is present in the analyzed stream.

� LFE Channel (Low frequency enhancement channel). The analyzer displays
yes or none to indicate whether a Low Frequency Effect is present in the
analyzed stream.

� Number of Channels. The total number of channels that are present in the
analyzed stream, including front channels, surround channels, and center
channel.

� Copyright. The analyzer displays yes or none.

� Original Copy. The analyzer displays yes or none.

Graphical Channel Indicator. The area in the upper-right corner of the Main
Characteristics window contains the Graphical Channel Indicator. In this area,
black blocks represent the audio channel configuration as explained in the
following table.

Block location Channels present in the stream

Upper left corner Left channel

Upper right corner Right channel

Middle of top line Center channel

Middle of bottom line Surround channel

Lower left corner Left surround channel

Lower right corner Right surround channel

Center of the square LFE channel
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In the example below, the Graphical Channel Indicator displays a frame with
three audio channels: a left channel, a right channel, and a surround channel.

Graphical Channel
Indicator

When you open an audio stream file, the Frame view automatically opens. You
can add additional views of the same frame by selecting Add view from the
Window menu or by selecting Add view in the Upper Toolbar and selecting
Frame view from the View Type submenu.

Adding views does not allow you to compare one frame with another. In order to
do so, you must display separate View windows directly from the parent view
window. (From the View menu select Frame view). You can also display frames
in Binary or Hexadecimal as explained on page 2–9.

The Frame view is a graphic representation of the elements associated with the
audio stream, one frame at a time. Each element is represented by an icon.
Double-click any of the icons to open a more detailed view (interpreted view)
with additional information. Interpreted views provide a graphical way to look at
AC-3 audio stream elements. You can navigate through each frame in the various
element files with the Edit Toolbar.

Frame View
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SI, BSI, AUX, and CRC Views. To open an interpreted view of the elements listed
below, double-click the icon in the Frame view. See the following pages in the
Reference section for additional information:

� SI (Synchronization Information) See page 3–5

� BSI (Bitstream Information) See page 3–5

� AUX (Auxiliary Data) See page 3–15

� CRC (Cyclic Redundancy Check) See page 3–16

Audio Block Views. When you double-click an Audio Block icon, the analyzer
displays several elements horizontally, representing the block’s primary syntactic
structure. These component elements are also positioned vertically, according to
information type:

� Common information

� Coupling channel

� Full Bandwidth channels (FBW)

� Low Frequency Enhancement channel (LFE)

With the Frame view active, you can select any audio block view (AB0-AB5)
either by double-clicking the desired icon in the Frame view, or by selecting it
through the View menu. You can also add an Audio Block view using the Add
view command from the Window menu or Upper Toolbar.

In every view dealing with the audio blocks of a frame, the displacement unit is
the block. All views display the current block number (from 0 to 5).

Each block icon represents real data read in the stream and their block represen-
tation represents the order of appearance in the frame. Read the structures from
left to right and from top to bottom.

The current frame determines the presence of icons representing the Dynamic
Range Control, the Rematrixing Flags, and the Delta Bit Allocation. The
following illustration shows the maximum expansion of the view.
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When the current view is an optional syntactic view such as Delta Bit Allocation,
the Next button may not find any other information of this type in the following
blocks, so the Next command may fail. In this case, terminate the search by
pressing the ESC key.

Audio Block Interpreted Views. When you double-click an Audio Block icon, the
analyzer displays an interpreted view of the MPEG elements listed below. The
display formatting changes depending on the type of data.

See the following pages in the Reference section for additional information:

� Block Switching See page 3–7

� Dither Flags See page 3–7

� Dynamic Range Control See page 3–7

� Coupling Strategy Information See page 3–8

� Coupling Data See page 3–8

� Rematrixing See page 3–9

� Exponent Strategy See page 3–10

� Exponents See page 3–10

� Bit Allocation See page 3–12

� Delta Bit Allocation See page 3–13

� Dummy Data See page 3–14

� Quantized Mantissas See page 3–15
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CRC Status Message. Each time you open a frame, the analyzer performs a CRC
analysis and displays the result at the bottom of the Frame view. This status
message indicates one of the following conditions:

� The entire current frame is valid.

� The first 5/8 frame is valid; the remaining data may be corrupt.

� The last 3/8 frame is valid.

� The entire frame is invalid.

CRC Status
Message

The Binary and Hexadecimal views display the audio bitstream for the AC-3
syntax indicated in the Top Line of the Frame view window.

To display a Binary or Hexadecimal view, do the following:

1. Click the Add view button in the Upper Toolbar or select Add view from the
Window menu.

2. Select the type of view you want to add: Binary or Hexadecimal. If a view is
dimmed in the menu, that view is unavailable.

Binary and Hexadecimal
View
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The Channel view displays the number and type of channels encoded in the
audio stream file.

Display the Channel view using the following procedure:

1. Navigate to the First Level view for the audio file.

2. Select Add View from the Window menu (or click the Add View icon from
the upper toolbar).

3. Select Channel View from the submenu, and the Channel view window is
displayed.

From the Channel view, you can decode all or part of the audio file by right-
clicking one of the icons and selecting the appropriate option from the submenu.
After that portion of the audio file has been decoded, the Wave Editor view is
displayed. See Decoding Audio Stream Files on page 2–13.

Channel View
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Immediately after you decode an audio stream file, the Wave Editor view
window is displayed. From this window you can view the decoded audio stream
waveform, play the decoded audio file, and save the audio file (or a portion of it)
as a .wav file. To listen to the decoded audio stream, you must have a sound card
installed on your computer.

To display the Wave Editor window, perform one of the decoding procedures
described in Decoding Audio Stream Files on page 2–13.

NOTE. The Wave Editor view window is displayed only after the analyzer has
finished decoding an audio stream file. The editing capabilities of the Wave
Editor are limited to selecting a portion of the decoded audio stream to save or
playback.

The following list describes the elements of the Wave Editor view window.
Table 2–1 on page 2–12 describes the Wave Editor toolbar elements.

� The title bar displays the decoded file name and location.

� The Wave Editor toolbar displays the controls you use to play, save, and
select portions of the waveform.

� The middle and bottom sections displays the analog waveform of one or
more decoded channels.

The bottom section displays the waveforms compressed to fit the width of
the view window. If Display in frames is checked in the Options menu, the
horizontal unit of measurement is audio stream frames. If Display in
milliseconds is checked, the unit of measurement is milliseconds.

Wave Editor View
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� The checkboxes to the left of the bottom section let you specify which two
channels to play when you listen to the .wav file.

� The 1/8th note indicates the position in the sound file as the decoded audio
stream is played.

� The total time (in seconds) and length (in frames) of the decoded audio file is
indicated in the lower right of the view window.

Table 2–1: Wave Editor toolbar elements  

Element Name Description

Play Starts playing the decoded audio file.

Unless you have selected a portion of the waveform, the
complete waveform is played when you select this
command button. If a portion of the waveform is
selected, only the selected portion of the sound file is
played.

Stop Stops playing the decoded audio file.

Pause/Resume Pauses and resumes playing the decoded audio file.

Save As Saves the decoded audio file.

Unless you have selected a portion of the waveform, the
complete waveform is saved when you select this
command button. If a portion of the waveform is
selected, only the selected portion of the sound file is
saved.

Position Sets the position of the cursor in the bottom part of the
Wave Editor view window.

Change the position of the cursor by selecting the up
and down buttons, or by clicking in the bottom waveform
display.

Selection Selects a portion of the audio file. The selected portion
of the audio file starts at the cursor position.

Change the selected portion of the waveform by
selecting the up and down buttons, or by clicking and
dragging in the bottom waveform display.

The selected portion of the waveform determines which
part of the audio file will be played and saved.
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Table 2–1: Wave Editor toolbar elements  (cont.)

Element DescriptionName

Zoom Sets a horizontal zoom factor for the upper waveform
display.

Change the zoom factor by selecting the up and down
buttons, or by moving the scroll bar.

Initially, the waveform is displayed at the highest zoom
factor.

Display Sets the unit of measurement used in the Wave Editor
view window.

Set the unit used for the Wave Editor by selecting either
Display in frames or Display in milliseconds from the
Options menu. The current unit of increment has a
check mark next to it in the Options menu.

You can add another Wave Editor view window using the following procedure:

1. Ensure that the Wave Editor view window is the active view window.

2. Click the Add View command button from the Upper toolbar.

Alternatively, select Add view from the Window menu.

You can decode audio streams and view the audio waveform (or waveforms)
using the Wave Editor window (see Wave Editor View, beginning on page 2–11).

As part of the decoding process, a .wav file is created for each channel encoded
in the audio stream that you choose to decode. The files for specific channels are
identified by appending the channel name and .wav to the prefix of the audio
stream file name. For instance, if the audio stream file you decode is named
��������	
�� (a five channel audio elementary stream file) and you decode all
channels in the stream, the following .wav files are written to the same directory
as the .ac3 file:

� �����������
���	�
� (center channel)

� �������������	�
� (left channel)

� ������������	�
� (LFE channel)

� ��������������	�
� (right channel)

� ����������������	�
� (left surround channel)

� �����������������	�
� (right surround channel)

Decoding Audio Stream
Files
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The following list describes the options available for decoding and saving audio
stream data:

� All channels for the complete audio stream

� All channels for a specific part of the audio stream

� Selected channels for the complete audio stream

� Selected channels for a specific part of the audio stream

There is more than one way to carry out each of the following procedures. Each
procedure shows only one way performing the indicated task.

Decoding a Complete Audio Stream. Decode all of the channels for a complete
audio stream using the following procedure:

1. Navigate to the First Level or Channel view window.

2. Click Separate Decoding form the Decode menu, and then select Decode
All Channels from the submenu.

The dialog box shown below is displayed.

3. In the Decoding Range dialog box, click Complete.

After the audio stream is decoded, the Wave Editor window is displayed (see
page 2–11).

Decoding Part of an Audio Stream. Decode all of the channels for part of a audio
stream using the following procedure:

1. Navigate to the First Level or Channel view window.

2. Click Separate Decoding from the Decode menu, and then select Decode
All Channels from the submenu.

The dialog box shown above is displayed.
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3. Select one of the following options from the Decoding Range dialog box:

� Partial Frames. If you select this option, enter the stop and start frames
in the text boxes to the right.

� Partial ms. If you select this option, enter the stop and start time in
milliseconds in the text boxes to the right.

After the file has been decoded, the Wave Editor window is displayed (see
page 2–11).

Decoding Specific Channels of Audio Streams. To decode a specific channel for
part of an audio stream, use the following procedure:

1. Navigate to the Channel view window.

a. Navigate to the First Level view for the audio stream you want to
decode.

b. Select Add View from the Window menu, and then select Channel
View from the submenu.

2. Right-click the channel icon for the channel you want to decode and select
Decode from the submenu .

The dialog box shown on page 2–14 is displayed.

3. Select one of the following options from the Decoding Range dialog box:

� Partial Frames. If you select this option, enter the stop and start frames
in the text boxes to the right.

� Partial ms. If you select this option, enter the stop and start time in
milliseconds in the text boxes to the right.

After the file has been decoded, the Wave Editor window is displayed (see
page 2–11).
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Downmixing Audio Stream Files. Use the downmixing capability of the Dolby
Digital Audio Stream analyzer to downmix or upmix an AC–3 audio stream file.

1. From a Channel View, select Downmixing from the Decode menu. The
following dialog box is displayed.

2. Select the output mode. The first displayed number in the Output mode
options represents the number of left, center, and right channels. The second
number represents the number of surround channels. The way in which the
analyzer downmixes (or upmixes) audio stream files corresponds to the
Dolby Digital documentation.

3. If appropriate, select whether or not to downmix the LFE channel.

4. Select the part of the stream you want to decode:

� Part of the stream by frames. If you select this option, enter the start
and end frames in the text boxes to the right.

� Part of the stream by milliseconds. If you select this option, enter the
start and end times (in milliseconds) in the text boxes to the right.

� The complete stream.

5. Click OK.

When the downmixing is completed, the Wave Editor is displayed (see
page 2–11).
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The analyzer can plot three types of graphs: Dialog Normalization, Heavy
Compression, and Dynamic Range. The analyzer plots the item number on the
horizontal axis and the value on the vertical axis. For additional information
about these graphs, see Graphical Views beginning on page 3–16.

To add multiple view windows to the Application window, select Add View
using the Upper Toolbar or the Window menu, and then select the view type you
want to display. When you display a new view with this method, the Edit
Toolbar functions navigate through all added views, active or inactive.

When the active view is an interpreted view, you can add a Binary or Hexadeci-
mal view of the information displayed in the interpreted view.

To add a view using the Add View command, do the following:

1. For this example, open the Synchronization Information (SI) view. Make
sure it is active (highlighted).

2. Click the Add view button in the Upper Toolbar, or select Add view from
the Window menu.

3. Select the view you want to add from the resulting menu. For this example,
select the Hexadecimal.

4. Use the Edit Toolbar to navigate to Frame 5. Both views change to show the
synchronization information for Frame 5.

You may find it useful to compare interpreted views of the various audio block
components. To compare blocks, items, and frames, do the following:

1. From the Audio Block view, double-click the icon for the audio block
component that you want to analyze. This displays the interpreted view for
that component.

2. Select the Audio Block View again (make it active), and double-click the
same icon as in step 1.

3. When the second audio block interpreted view window appears, dismiss the
Audio Block View window.

4. Use the Edit Toolbar buttons to navigate to the desired blocks, items, and
frames. Only the active window changes, allowing you to compare the fields
and values of the various items between windows.

Graphical Views

Adding Views
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The following table shows the available views:

From this view window You can display

Frame view � Additional Frame view
� Binary or Hexadecimal view
� Additional Main Characteristics view
� Channel view

Interpreted view � Additional interpreted view
� Binary or Hexadecimal view

Binary or Hexadecimal view � Interpreted view of the syntax
� Binary or Hexadecimal view

Main Characteristics � Additional Frame view
� Binary or Hexadecimal view
� Additional Main Characteristics view
� Channel view

Channel view � Frame view
� Binary or Hexadecimal view
� Main Characteristics view
� Additional Channel view

Wave Editor view � Additional Wave Editor view

Using Menus
The analyzer menus allow you to execute commands and access the main
syntactic views. You can use the keyboard or mouse to access the analyzer
menus. You can also use the Upper Toolbar buttons as shortcuts to some menu
selections.

Using the Keyboard. To open a menu, press and hold the ALT key while you
press the underlined letter in the menu name. For example, to open the File
menu, press and hold the ALT key while you press F. To select a command after
you open a menu, press the underlined letter in the command name, or use the
arrow keys to highlight the command and then press ENTER. To close a menu,
press the ESC key.

Using the Mouse. To open a menu, click the menu name in the Menu Bar. To
select a command from an open menu, click the command name. To close a
menu, click outside the menu.

Using the Upper Toolbar. Click an icon in the Upper Toolbar to open the
associated submenu or to execute the associated command.
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Table 2–2 describes each of the menu selections.

Table 2–2: Menu selections 

Menu Selection Description

File Open Displays the Open dialog box to identify the existing
audio stream file you want to view. Identical to the
Open button on the Upper Toolbar.

Close Closes the active audio stream.

Save as Displays the Audio Stream Saving dialog box to
specify how much of the stream you want to save.
After you select OK, a standard Save As dialog box
displays. Same as the Save as button on the Upper
Toolbar.

Print Displays a standard Print dialog box to print the
active view window.

Printer setup Displays the Page Setup dialog box from which you
specify the paper size, orientation, and page
margins. The dialog box also provides access to
printer options.

Exit Ends the session and closes the Dolby Digital Audio
Stream Analyzer application.

Edit Next Item Displays the next item in the audio stream.

Previous Item Displays the previous item in the audio stream.

First Item Displays the first item in the audio stream.

Last Item Displays the last item in the audio stream.

Go to Displays the specified item in the audio stream.

Number of Items Calculates the number of items in the active view
and displays the number in the upper portion of the
active view window.

Next error Displays the next item in the audio stream that
contains an error.

View Main Characteristics Opens a Main Characteristics Frame view window
of the audio stream indicated in the Title Bar.

Frame view Opens a Frame view of the audio stream indicated
in the Title Bar.

SI View Opens a Synchronization Information view. Same as
double-clicking on the SI icon in the Frame view.

BSI View Opens the Bit Stream Information view. Same as
double-clicking on the BSI icon in the Frame view.
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Table 2–2: Menu selections (cont.)

Menu DescriptionSelection

Audio Block View Displays a submenu of Audio Blocks 0 through 5.
Selecting any block opens the corresponding Audio
Block view. Same as double-clicking any of the
Audio Block icons (AB0-AB5) in the Frame view.

Auxiliary Data View Opens the Auxiliary Data View. Same as double-
clicking on the AUX icon in the Frame view.

CRC View Opens the CRC (error checking) view. Same as
double-clicking on the CRC icon in the Frame view.

Analysis Syntactic Performs a Syntactic analysis on the audio stream
indicated in the Title Bar of the secondary window.

Semantic Performs a Semantic analysis on the audio stream
indicated in the Title Bar of the primary window.

Automatic Performs the analyses you selected in the Options
menu for Automatic Analysis.

Decoding Downmix Displays the Downmixing dialog box, from which
you select the mode in which you want to downmix
(or upmix) an audio stream file.

Separate Decoding Displays a submenu allowing you to specify which
channel you want to decode (the list of available
channels depends on the number and type of
channels encoded in the active file).

Stream Summary Generates a textual stream summary.

Graph Displays a submenu allowing you to select from
three graphical displays: the Dialog Normalization
graph, the Heavy Compression graph, and the
Dynamic Range graph.

Options Base Displays the Base dialog box to set the numeric
base (decimal or hexadecimal) of the values
displayed in the interpreted views.

Font Displays the Font dialog box to set the type,
typeface, and size of the font used for most of the
views windows. The Binary and Hexadecimal view
windows are not affected by the font selection.

Interpretation Displays the Interpreted view option dialog box to
display either the length or position of the field in the
bitstream. This information is displayed in
interpreted views and available only in Linear
format.

Output Message in File Automatically saves analyses results error
messages to a file. You can specify the path using
the Directories command.
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Table 2–2: Menu selections (cont.)

Menu DescriptionSelection

Directories Sets the default path for saving messages to file
and for saving and loading configuration files
(Configuration Directory).

Automatic Analysis Opens a dialog box to select the analyses
performed (Syntactic, Semantic, or both) when you
select Automatic from the Analysis menu.

Read Configuration Displays the Read Configuration dialog box to
specify which previously saved configuration file
(*.acf) to load into the current analyzer session.

Display in Frames Sets the unit of measure to frames in the Wave
Editor

Display in Milliseconds Sets the unit of measure to milliseconds in the
Wave Editor

Save Configuration Displays the Save Configuration dialog box to save
the current analyzer configuration to file (*.acf). You
can transfer the file to another system or reload it at
a later time.

Set Default Configuration Loads the default configuration file.

Window Cascade Displays the open view windows on top of one
another, enlarging the Main Characteristics window
if necessary.

Tile Fits the open view windows to the application
window.

Arrange Icons Arranges all minimized windows from left to right
across the bottom of the application window.

Close view Closes the active audio stream file.

Close all Closes all view windows.

Add view Opens a submenu to create an additional view of
the current data. The submenu changes depending
on your selection. Same as the Add View button on
the Upper Toolbar.

Help Contents Opens the Dolby Digital Audio Stream Analyzer
Online Help. Select an analyzer help topic or click
on a tab to the view the index or specify a search
topic.

Using help Opens the Windows Online Help window. Select a
Windows help topic or click on a tab to the view the
index or specify a search topic.

About Audace Displays the analyzer version number and copyright
information.
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Audio Stream Analysis
This section explains how to open, decode, analyze, save, and print audio stream
files.

To extract and analyze an audio elementary stream encoded in a transport stream
file, use the following procedure:

1. Identify the audio stream PID for the packets of interest. If necessary,
examine the transport stream first with the MTS 300 MPEG-2 DVB/ATSC
System Analyzer (Deferred-Time Analyzer application).

2. Select Open from the File menu.

3. Select the appropriate file from the Open dialog box.

4. Enter the PID of the packets that contain the audio stream.

NOTE. If you have the Tektronix MTS 300 MPEG-2 DVB/ATSC System Analyzer,
you can open the Dolby Digital Audio Stream Analyzer to analyze Dolby
elementary streams. From the Deferred-Time Analyzer Hierarchic View,
right-click the Dolby audio icon and select AC-3 Stream Analyzer from the
pop-up menu.

Saving Audio Stream Files. You can save AC-3 audio stream files as *.AC3 files.

To save all or part of an audio stream file, use the following procedure:

1. Open an AC-3 audio stream file or other file containing an AC-3 audio
stream (see Audio Stream File Types on page 1–1).

2. Make sure that the Frame view is active.

3. Select Save as from the File menu or click the Save As button on the Upper
Toolbar.

Extracting an Audio
Elementary Stream from a

Transport Stream
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4. In the Audio Stream Saving dialog box, specify what portion of the stream
you want to save by selecting one of the following options:

� All the audio stream. This option is the default for storing encoded
streams and will save the complete audio stream.

� From frame. This option allows you to save a specific portion of the
audio stream. Enter the starting frame in the From Frame text box and
the length of the frame in the length text box.

� From milliseconds. This option allows you to save a specific portion of
the audio stream. Indicate the starting time in the From millisecond text
box and number of the milliseconds in the duration text box.

5. Select the number of times you want to save the audio data in the Repetition
Count text box, and then click OK. For each repetition greater than one, the
audio stream or the selected portion will be appended to the first repetition.
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6. You are prompted for the audio stream file name with the following dialog
box.

7. Select or type the file name and extension, and then select OK.

You can analyze audio streams for errors in the following ways:

� Syntactic Analysis. Search for errors in the value(s) of a structure.

� Semantic Analysis. Search for errors in the MPEG structure.

� CRC Check. Search for errors in transmission or decoding.

� Automatic Analysis. Perform a series of analyses of an entire stream.

Syntactic Analysis. Syntactic analysis detects when a field has a value disallowed
by the Dolby AC-3 standard, independently of any other field (typically a bad
frame header). Some fields can have a reserved value, which could make some
decoders crash. When no default value is defined in the standard, a reserved
value is considered a syntax error and will generate an error message.

Syntactic analysis is available when the active view contains syntactical
analyzable material (for example, the Delta Bit Allocation view). Otherwise, the
menu command is unavailable, for example, when the Main Characteristics view
is active.

The analyzer can perform syntactic analyses on a specific MPEG2 AC-3 audio
stream syntax or on the complete stream.

To analyze a specific syntax, do the following:

1. Display the interpreted view window for the syntax you want to check. For
example, in the Frame view, double-click on the BSI icon to analyze the Bit
Stream Information syntax.

Analyzing Audio Streams
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2. To provide a complete inventory of each incorrect field, select Syntactic
from the Analysis menu. The analyzer performs syntactic analysis on the
open window. The frame number in the Top Line of the interpreted view
cycles through the frames of the audio stream to indicate that the analysis is
being performed. If you want to stop the analysis, press ESC. Detected
syntax errors are displayed in a Message for... window.

3. To display one error at a time, select Next error in the Edit Toolbar display.

4. In the displayed SI or BSI view, the errors are displayed in red. Double-click
on the error to display an explanation.

To analyze the entire stream, perform an automatic analysis with the Syntactic
analysis option checked (see Automatic Analysis below).

Semantic Analysis. Semantic analysis checks the coherence of all AC-3 parame-
ters as indicated by the standard. You can perform semantic analyses only from
the Frame view.

To perform a semantic analysis, use the following procedure:

1. Navigate to the Frame view.

2. Select Semantic from the Analysis menu.

3. The analyzer performs a semantic analysis of the entire stream and reports
any errors in an error message window.

4. Double-click an error message to display the interpreted view of the element
in error.

To analyze the entire stream, perform an automatic analysis with the syntactic
analysis option checked (see Automatic Analysis below).

Automatic Analysis. You can use the Automatic Analysis function to perform
syntactic analysis, semantic analysis, or both. This function is only available
when the Frame view is active.

To perform an automatic analysis, use the following procedure:

1. Select which analyses to perform:

a. Select Automatic analysis from the Options menu.

b. In the resulting dialog box, select Syntactic, Semantic, or both types.

c. Click OK.

2. Be sure that the Frame view is active.

3. Select Automatic from the Analysis menu.
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4. The analyzer performs the analyses that were selected in the Options menu.
If Syntactic is selected, a syntactic analysis is performed on the complete
audio stream.

5. A message window displays the results of the analysis. If the analyzer
detects errors, Errors appears in the right column. Double-click the word
Errors to display the error message window.

CRC Error Check. CRC information is displayed in two ways:

� Each time you open a frame, the analyzer performs a CRC analysis and
displays the result at the bottom of the Frame view. For more information
about this display, see Frame View on page 2–9.

� The AC-3 stream contains two CRC words per frame. You will find CRC1
in the results of the first five-eights of the frame; CRC2 occurs in the results
of the last three-eights of the frame. For an interpreted view of CRC1,
double-click the SI icon to open the CRC view. For an interpreted view of
CRC2, double-click the CRC icon to open the CRC view.

For more information about this display, see Cyclic Redundancy Check on
page 3–16.

You can decode an audio stream and view the audio waveform using graphical
views. See the following pages in the Reference section for additional informa-
tion:

� Dialog Normalization graph See page 3–16

� Heavy Compression graph See page 3–17

� Dynamic Range graph See page 3–17

To generate a stream summary, use the Stream Summary command from the
Decode menu. For more information, see Stream Summary on page 3–17.

Decoding Audio Streams



Operating Basics

MPEG Test System Dolby Digital Audio Stream Analyzer 2–27

You can print any of the view windows except the Main Characteristics view. To
print the information displayed in a view window, use the following procedure:

1. Specify the page layout by selecting Printer setup from the File menu.
Make appropriate selections for paper size and source, orientation, and
margins from the Page Setup dialog box.

2. Specify the printer connections by selecting the Printer command button,
and then making the appropriate printer and printer properties selections (see
your Windows documentation).

3. Return to the view window you want to print and select Print from the File
menu.

4. In the Print dialog box, make selections and print the contents of the active
view window.

NOTE. You may need to change the font and page margins to print all the
information displayed in some of the interpreted view windows.

You can load a previously saved configuration file (.acf file) into the current
analyzer session by selecting the Read configuration command from the
Options menu. This operation will affect the base, font, and interpretation
parameters.

Printing Audio Stream
Data

Loading a Configuration
File
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Reference

This section provides detailed information on the Dolby Digital Audio Stream
Analyzer. and is organized into the following subsections:

� Binary and Hexadecimal Views. Describes how you can use these views to
display and interpret audio stream data.

� Interpreted View Displays. Describes how to interpret tabular and linear
display formats.

� Interpreted Frame Views. Describes how to open an interpreted view of any
element in the Frame view.

� Graphical Views. Describes how to generate normalization, compression,
and dynamic range graphs.

� Error Messages. Describes how to interpret the syntactic and semantic
analyses error reports.

� Configure Analyzer Parameters. Describes the Options menu selections.

Binary and Hexadecimal Views
The Binary and Hexadecimal windows display the audio bitstream for the MPEG
element indicated in the top line of the interpreted view window.

Use one of the following techniques to display a Binary or Hexadecimal view:

� From an interpreted view, click the Add view Toolbar button, and then select
either Binary or Hexadecimal from the submenu.

� From an interpreted view, select Add view from the Window menu, and then
select either Binary or Hexadecimal from the submenu.

The Edit Toolbar is available for both views, so you can step through the binary
or hexadecimal information for other frames. When you select Next error, the
analyzer looks for syntactic errors and not semantic errors.
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Interpreted View Displays
These displays allow you to interpret the values of the various AC-3 elements.
Two types of displays are available: tabular and linear. Both displays are
interactive, allowing you to determine which signal you are viewing when you
examine the syntax.

Tabular Display. Tabular displays are interpreted views that present the extracted
information in tabular format, such as the following view.

In addition to the information common to all interpreted views, tabular views
have the following unique features:

� Information is presented in table format.

� Row and column headings provide access to descriptions of the displayed
syntax.

� Data displayed in the cells is one of two types: actual values for AC-3
parameters or indices for a set of values from the standard.

� Red values indicate syntax errors.

You can double-click a row or column heading to display a description of the
contents. You can also double-click a cell to interpret its data. To display data in
decimal or hexadecimal format, press the F2 function key.

When you double-click a cell or heading, a message box appears. The Title Bar
of the message box indicates the specific syntax displayed. You can position the
box anywhere within the view window by clicking and dragging the Title Bar of
the box. Click anywhere outside of the box to dismiss it.
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Linear Display. Linear displays are interpreted views that present the extracted
information in a series of rectangles, such as the following view.

In addition to the information common to all interpreted views, linear views have
the following features:

� Large rectangles display parameter names. You can double-click a large
rectangle to display a message box containing the parameter description. You
can move this message box anywhere within the view window by clicking
and dragging the Title Bar of the box. Click anywhere outside the box to
dismiss it.

� Shaded large rectangles denote important AC-3 parameters.

� Small rectangles display the parameter value. You can double-click a small
rectangle to display a message box containing an interpretation of the
displayed value. Click anywhere outside the displayed message box to
dismiss it.

� Values displayed in red indicate syntax errors.

You can display parameter values in decimal or hexadecimal format. To switch
between the two, press the F2 function key. Alternatively, select Base from the
Options menu, and then make the selection from the dialog box that is displayed.

Linear displays can indicate the position or length of a parameter in the
bitstream. When enabled, this information appears below the small rectangles.
You can determine which type of information to display, if any, using the
following procedure:

1. Select Interpretation from the Options menu.

2. Select Position or Length, or deselect both options.

� Position indicates the position in the bitstream of the first bit of the
parameter. Position is relative to the first bit in the displayed element.

� Length is the length in bits of the parameter.
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Each time you start a new session, the analyzer uses the Interpretation option
selected from the previous session. The default Interpretation option displays
neither length nor position information.

Using the Toolbar to Navigate .You can use the Edit toolbar to navigate through
the elements of an audio stream file. (See Edit Toolbar on page 2–2.) In the
Frame interpreted view, the � button takes you to the displayed element in the
next frame. In an Audio Block view, the � button takes you to the next item or
block.

In the interpreted view, the analyzer looks for syntactic errors (not semantic
errors) when you click the Next error button in the Edit toolbar. (The Edit
toolbar is inactive in the Frame view.) If you select Next error while the CRC
interpreted view is displayed, the analyzer displays the next detected CRC error.

Interpreted Frame Views
To open an interpreted view of any element in the Frame view, double-click the
icon of interest. Double-click any resulting cell to read an interpretation of the
data for that cell.
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Double-click the SI icon from the Frame view to display a graphical representa-
tion of the Synchronization Information. This view uses a linear display.

Double-click the BSI icon from the Frame view to display a graphical represen-
tation of the Binary Stream Information. This view uses a linear display.

The BSI view displays several fields of information, depending on the mode.
Optional field indicators (like ComprE, AudProdIE) appear in white on the
screen. Data found in the additional field cannot be displayed, you must click the
data area to open a raw view window.

Double-clicking the large rectangle identifies the field data. (The format
displayed depends on the frame from which you accessed the Auxiliary Data
interpreted view.) Double-clicking the small rectangle displays the message Bit

Synchronization
Information (SI) View

Binary Stream Information
(BSI) View
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value. In order To use the Next error button on the Edit toolbar, display the
bitstream first by double-clicking on the large rectangle.

Double-click an Audio Block icon (AB0 – AB5) from the Frame view to display
the Audio Block view.

Double-click an Audio Block view icon to display an interpreted view window
of detailed information for the current frame. Double-click any resulting cell to
read an interpretation of the data for that cell.

The following section discusses the individual Audio Block interpreted views.

Audio Block Views
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Block Switching View. This view displays a block switching flag for each full
bandwidth channel (a maximum of five channels). These flags indicate whether
the current audio block was split into two sub-blocks during transformation from
the time domain into the frequency domain.

The following AC-3 data is displayed:

� BlockSw (for each full bandwidth channel)

Dither Flags View. This view displays a dither flag for each full bandwidth
channel (a maximum of five channels).

The following AC-3 data is displayed:

� DithFlg (for each full bandwidth channel)

Dynamic Range Control View. This view displays the current frame fields; data is
common to all channels. These fields may also be traced in the Dynamic Range
graph (see page 3–17), in which case the unit is a block instead of a frame.

The following AC-3 data is displayed:

� DynRngE

� DynRng
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� DynRngE

� DynRng2

Coupling Strategy Info View. This view displays coupling strategy and channel
data for each full bandwidth channel.

The following AC-3 data is displayed:

� CplStrE

� CplInU

� ChInCpl (for each channel)

� ChsFlgInU

� CplBegF

� CplEndF

� CplBndStrc (for each coupling frequency sub-band)

Coupling Data View. This view displays coupling channel data for each full
bandwidth channel. In the upper array of this view, the length of the fields or the
relative position to the beginning of the syntactic portion is given in the field
interpretation (not shown).
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The following AC-3 data is displayed:

� CplCoE and MstrCplCo (for each channel)

� CplCoE[ch][bnd] (coupling coordinates exponent). Represented in a
two-dimension array, up to 18 bands are displayed; unused bands are crossed
out.

� CplCoMant[ch][bnd] (coupling coordinates mantissa). Represented in a
two-dimension array, up to 18 bands are displayed; unused bands are crossed
out.

� PhsFlg (for each coupling band up to 18)

Rematrixing View. This view displays data about full bandwidth channels only.

 The following AC-3 data is displayed:

� RematStr. If Rematr is on, the array of rematrixing flags is displayed
(RematFlg[ch]).
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Exponent Strategy View. This view displays the following AC-3 data:

� CplExpStrat (reuse, D15, D25, D45)

� chexpstr (for each channel)

� LfeExpStr

� ChBwCod[ch] (channel bandwidth code)

Exponents View. There are three exponents views; one for each channel type
listed along the left side of the Audio Block view window. Icons for one or more
of these channels appears in the Audio Block view.

Exponents for the Coupling Channel. This view displays the following AC-3
data:

� CplAbsExp (coupling absolute exponent)

� CplExps (for each group of three exponent values for the coupling channel)
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Exponents for the Full Bandwidth Channel(s). This view displays the following
AC-3 data:

� Exps[ch][0] (absolute exponent values)

� Exps[ch][grp] (values of each group for the other channels: 85 columns)

� Gainrng[ch] (channel gain range code)

Exponents for the LFE channel. This view displays the following AC-3 data:

� LfeExps[0] (absolute initial exponent)

� LfeExps[gr] (values of each group for the LFE channel gr)
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Bit Allocation View. This view displays the following AC-3 data:

� baie, SDcyCod, FDcyCod, SGainCo, DbPBCo, FloorCod, SnrOffstE

� CSnrOffst

� FSnrOffst

� CplFSnrOffst, CplFGainCod

� FSnrOffst and FGaincod (for each channel)

� LfeFSnrOffst, LfeFGainCod

� CplLeakE, CplFleak, CplSLeak

� DeltBAIE (Delta Bit Allocation Information )
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Delta Bit Allocation View. There are three types of Delta Bit Allocation views.
Depending on the audio stream file, one or more of these icons may appear in the
Audio Block view.

Common Delta Bit Allocation. This view displays the following AC-3 data:

� CplDeltBAE

� DeltBAE[ch]

Delta Bit Allocation for the Coupling Channel. This view displays the following
AC-3 data:

� CplDeltNSeg

� CplDeltOffst[seg

� CplDeltLen[seg]

� CplDeltBA[seg]
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Delta Bit Allocation Information for FBW Channel(s). This view displays the
following AC-3 data for each full bandwidth channel:

� DeltNSeg[ch]

� DeltOffst[ch][seg]

� DeltLen[ch][seg]

� DeltBA[ch][seg]

Dummy Data View. Dummy data is common to all channels. This view displays
the following AC-3 data:

� SkipLE

� SkipL

� SkipFld
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Quantized Mantissas View. The mantissa view is considered a common view
because the channel order is standard: full bandwidth coupled channels, followed
by the coupling channel and full bandwidth non-coupled channels, and finally,
the LFE channel. There is a matrix for each channel type and a separate LFE
mantissa view. Order of appearance in the stream is respected:

This view displays the following AC-3 data:

� ChMant[ch][bin] (full bandwidth coupled channels)

� CplMant[bin] (coupling channel)

� ChMant[ch][bin] (full bandwidth non-coupled channels)

� LfeMant[bin]

Double-click the AUX icon in the Frame view to display a graphical representa-
tion of the auxiliary data view. This view uses a tabular display.

Auxiliary Data (AUX) View
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Double-click the CRC icon from the Frame view to display a graphical
representation of the CRC error syntax. This view uses a linear display.

The small rectangle in the CRC error interpreted view displays the CRC value.
Red values indicate errors. Display other CRC errors by selecting the Next error
button in the Edit toolbar.

Graphical Views
You can plot the following types of graphs with the Dolby Digital Audio Stream
Analyzer: Dialog Normalization, Heavy Compression, Dynamic Range. The
analyzer plots the stream element field values on the vertical axis and their
corresponding frame numbers on the horizontal axis. If you need to abort during
the graphing process, press the ESC key.

After the analyzer plots the graph, use the Edit Toolbar to navigate through the
blocks, items, and frames.

This graph is available only from the Frame view.

To generate the Dialog Normalization graph, do the following:

1. Be sure that the Frame view is active.

2. From the Decode submenu select Graph; then select Dialog Normalization
from the submenu.

3. Enter a number to specify at which frame to start the graph.

4. Enter the number of frames to plot.

5. Click OK. The displayed graph shows the frame numbers you specified on
the horizontal (X) axis and the dialog normalization values on the vertical
(Y) axis. Interpreted values are represented in decibels.

Cyclic Redundancy Check
(CRC) View

Dialog Normalization
Graph



Reference

MPEG Test System Dolby Digital Audio Stream Analyzer 3–17

This graph is available only from the Frame view.

To generate the Heavy Compression graph, do the following:

1. Be sure that the Frame view is active.

2. From the Decode menu select Graph; then select Heavy Compression from
the submenu.

3. Enter a number to specify at which frame you want the graph to start.

4. Enter the number of frames to plot.

5. Click OK. The displayed graph shows the frame numbers you specified on
the horizontal (X) axis and the heavy compression values on the vertical (Y)
axis. Interpreted values are represented in decibels.

This graph is available only from the Audio Block view.

To generate the Dynamic Range graph, do the following:

1. Be sure that the Audio Block view is active.

2. From the Decode menu select Graph; then select Dynamic Range from the
submenu.

3. Enter a number to specify at which frame you want the graph to start.

4. Enter the number of frames to plot.

5. Click OK. The displayed graph shows the frame numbers you specified on
the horizontal (X) axis and the dynamic range values on the vertical (Y) axis.
Interpreted values are represented in decibels.

To generate a stream summary, be sure the Frame view is active, and then select
the Stream Summary command from the Decode menu. The displayed
information (such as version number, sample frequency, and type) is the same for
all successive frames until new information appears.

Heavy Compression
Graph

Dynamic Range Graph

Stream Summary
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For example, in the following illustration the displayed information is the same
for frames 1 through 312.

Error Messages
When you perform a syntactic or semantic analysis, the analyzer generates an
error report if it finds any incorrect fields.

To display error messages in the interpreted view, click the Next error icon on
the Edit toolbar. This will advance through all the error messages, one at a time.
The error values are displayed in red. You can double-click the value to display
an explanation of the error.

Each line in the error report contains the following information:

� The frame number

� The block number

� The level of error

� The type of error (semantic or syntactic) in the case of Automatic analysis

� The name of the error (such as CRC error or synchronization error)

To save error messages to a file, select Error messages from the Options menu.
For additional information, see page 3–21.

Error Reports

Saving Error Messages to
a LOG File
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Configure Analyzer Parameters
You can configure several analyzer parameters. You can also save the configura-
tions and load them again (or transfer them to another analyzer), and you can
reset the parameters to default conditions.

You can specify which analyses to perform when you select Automatic from the
Analysis menu. You can also set the default directories that will be used when
saving error messages to a file and when saving and loading configuration files.

NOTE. The Options menu selections apply to the analyzer and not the audio
streams displayed. Consequently, when an audio stream is opened, the
information displayed reflects the current analyzer configuration. When you
begin a new session, the analyzer loads the configuration options used during
the previous session, saved when you exited.

You can save the current analyzer settings to a configuration file that you can
transfer to another system or reload at a later time.

Save. To save the configuration to a (*.acf) file, do the following:

1. Use the Options menu to select the desired Base, Font, and Interpretation
settings.

Menu item Description

Base Use this selection to determine how the interpreted views display the audio
elementary stream data. The analyzer can display data in either decimal or
hexadecimal base. You can enter values only in decimal base.

Font Use this selection to determine which font is in use in some analyzer view
windows. The Main Characteristics, Binary and Hexadecimal view windows
use a fixed font and are not affected by the font selection.

Interpretation This selection allows you to display the length or the position of a field in the
bitstream. This information is only available in linear display view windows.

Position indicates the position in the bitstream of the first bit of the field.
Position is relative to the to the first bit in the displayed structure.

Length is the length of the field in bits.

Saving and Loading
Configuration Files
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2. Select Save configuration from the Options menu.

3. Select the desired path and enter a file name for the configuration file. You
can also select an existing configuration file to write over.

4. Click Save. The .acf suffix will be added automatically.

Load. To load a configuration file, do the following:

1. Select Read configuration from the Options menu.

2. Select the configuration file that you want to load.

3. Click Save. The analyzer settings will be reset to the saved settings.

Set Default Directories. To assign a default directory for saving and retrieving
configuration files, do the following:

1. Select Directories from the Options menu.

2. Under Configuration Directory, enter the path that you want to use when
saving an loading configuration files.

3. Click OK.

To reset the configuration parameters to the defaults, select Set default
configuration from the Options menu and click Yes in the dialog box. The
analyzer uses the defaults listed in the table below.

Menu item Default setting

Base Decimal

Font Times New Roman, Regular style (no italics or bold), 9 point size

Interpretation No length or position display selected

Setting the Default
Configuration
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You can set the analyzer to automatically save error messages in a file.

To set the Default Directory, do the following:

1. Select Directories from the Options menu.

2. Under Message directory, enter the path to the directory where you want the
error message file stored.

To save error messages, do the following:

1. Select Output message in file from the Options menu.

2. Perform an analysis. If the analyzer finds errors, it creates an error message
file (*.log) in the directory you specified. Where * is the name of the AC-3
file.

To open an error message file, navigate in Windows to the specified directory
and locate the *.log file. For example, the error file created is called <xxx>.log.
Open the file in a word processing program, such as WordPad.

Saving Error Messages to
a File
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View window
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print, 2–27
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channel, 3–13
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